View Single Post
Old 10-17-2001, 11:18 PM
JimSmith JimSmith is offline
Join Date: Jul 2001
Location: Old Lyme, Connecticut
Posts: 3,596

I second the opinion you should fix it yourself. I have a 190E that has a simpler set up (no tilt feature) but failed and began to show signs of electrical gremlins. Once I got the interior roof panel off, and with some help from a number of regulars on this forum, I got to work. In the end, it cost me $0.37 for a new metal clip that connects the cable to the sunroof. The electrical issues were very unusual, the switch only worked in the direction of closing the roof, and only when you pushed the switch to open the roof. Once I wound the cable back in by hand, the thing started working in both directions again, and it now opens when I push the button to open it, and closes when I push the button to close it. I think is has a limit switch that needs to be reset once the cable comes out of the drive nut on the motor. Anyway, I highly recommend you get into it as it proved relatively simple and saved me a lot of money. Jim
1986 Euro 190E 2.3-16 (291,000 miles),
1998 E300D TurboDiesel, 231,000 miles -purchased with 45,000,
1988 300E 5-speed 252,000 miles,
1983 240D 4-speed, purchased w/136,000, now with 222,000 miles.
2009 ML320CDI Bluetec, 89,000 miles

1971 220D (250,000 miles plus, sold to father-in-law),
1975 240D (245,000 miles - died of body rot),
1991 350SD (176,560 miles, weakest Benz I have owned),
1999 C230 Sport (45,400 miles),
1982 240D (321,000 miles, put to sleep)
Reply With Quote