View Single Post
Old 03-18-2002, 02:05 PM
HGV HGV is offline
Registered User
Join Date: Sep 2001
Location: San Francisco
Posts: 357
1987 300TD running hot

I have a 1987 300TD with 200K miles. About 15K miles ago the car over heated, into the red, because of low fluid level in the radiator that was leaking. Replaced the radiator, thermostat, hoses, and serpentine belt. Car contiued to run hot, at about 100deg C. with the temp fluctuating with load. This all began to happen after it over heated the first time.. Car gradually got worse and began to make lifter noise. Decided to remove head and do a vlave job and replace all the lifters. Also replaced water pump and visco fan clucth. Car ran much better but still runs hot with fluctuating temp. Oil cooler was swapped with another car. No change. Finalyl decided to change oil thermostat this weakend as a last ditch effort to solve problem. No change. Where is the next place to look? Also I changed the temp sending unit early on. It almost seems that the termostat opening point is off,but I have changed it twice. I have gotten so fed up that I feel like selling the car, but it runs well outside of this temp problem. Also ambiant temp has minimal effect on engine temp. It was 42deg F this moring and car still ran hot.
63 190d (sold)
69 220D (sold)
69 280SL (sold)
76 BMW 2002 (sold)
86 190E-16v(best 4 banger around) 195k
87 300SDL (sold)
87 300TD 280k (sold)
95 E320W 211k
95 E320w 111k
05 C320 4matic
06 E320 CDI 90k
2013 GLK 250 Bluetek 4MATIC
Reply With Quote