View Single Post
Old 04-25-2002, 03:45 AM
David C Klasse's Avatar
David C Klasse David C Klasse is offline
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
Check the OVP fuse!! OVP = Overvolt Protection Relay.

Do a SEARCH (top right hand corner of page), and type in OVP... these relays are commonly faulty on this engine. Also many times a jump start can cause them to go bad (or simply blow the fuse).

The part is only about $50 and you can install it yourself in 2 minutes... very easy. You can purchase it on this website (FASTLANE / PARTSSHOP), for a very good deal.

Open the hood of the car:

In the top left part of the picture, there is a panel (just behind coolant reservoir) which covers the car's computer and sensitive electronic equipment. Pull up this panel.

This is a picture under that panel. In the lower right hand corner is labeled OVP in yellow (hard to see). It is a metal relay with a plastic fuse cover on top. Check these fuses first. If your OVP hasn't ever been replaced, I'd replace it without a doubt.

Good luck... I hope this will be the solution to your problem. (Also OVP causes NO warm starts... engine turns when engine is warm, but does not start).

Keep us posted!
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote