View Single Post
  #153  
Old 01-18-2011, 05:21 PM
BodhiBenz1987's Avatar
BodhiBenz1987 BodhiBenz1987 is offline
Registered User
 
Join Date: Dec 2004
Location: East Coast
Posts: 3,005
I ended up postponing the alignment due to an ice storm. Good thing because the car wouldn't start ... it didn't even crank. I took the battery to Advanced and it needed a charge, not surprising considering I left it hooked up for three months and I have an amp in the car that probably drained it. The dome light still worked, but the glow plug indicator was dim and the buzzer was a bit wimpy, so I really hope it's not starting was on account of the battery, not something more obnoxious! I had to go to work so I won't get to try until my shift is over in 8 hours. New alignment appointment is Thursday. I'm so anxious to find out if everything was a success. For some reason I'm particularly nervous about the axles ... I just feel underqualified to take apart and put together something that complex (well, it seemed complex to me). Maybe I should have more confidence.
I did get the exhaust put back on though ... and straightened it out ... before it was crooked and touching the bumper. So everything's done. Just waiting for the big test!
__________________
1987 300D, arctic white/palomino--314,000 miles
1978 240D 4-speed, Euro Delivery, light ivory/bamboo--370,000 miles
2005 Jeep Liberty CRD Limited, light khaki/slate--140,000 miles
2018 Chevy Cruze diesel, 6-speed manual, satin steel metallic/kalahari--19,000 miles
1982 Peugeot 505 diesel, 4-speed manual, blue/blue, 130,000 miles
1995 S320, black/parchment--34,000 miles (Dad's car)
Reply With Quote