View Single Post
Old 03-16-2000, 12:42 PM
revbond revbond is offline
Registered User
Join Date: May 1999
Location: Berkeley, CA
Posts: 199
Well, this problem has been resolved, sort of. After giving up, I took the car to two independent shops. The first, a two person operation (one of whom an elder german fellow), tried all the usual tests (temp sensors, push button units, etc) and could not find the problem. He felt that he could continue only if I gave him license to spend unlimited time till the problem was identified (essentially checking every wire and every connection). I would have been ok with this since, really, what choice did I have, and it is clear that the answer was not obvious. He, oddly enough didn't feel so comfortable about it. By the way, he didn't charge me for the time since he didn't solve anything. I told him I would get back to him.

I decided to try another independent shop with about 10 techs (the local mercedes dealer shop would not take it with the dash removed. They would prefer to have the dash installed, so they could charge me to remove it again). These guys, again, did the usual tests, tried numerous different pushbutton units and, of course, were dumbfounded. Until one had a recollection: this same problem had occured, twice before, on 190s. The solution? A push button unit from a more recent model year.

In went push button unit from model year 89, and out went the problem. I don't understand why. They don't understand why (other than the 89 unit has a slightly different pin configuration). All the flaps work. The fan shuts off when I push the "o" button. The defrost button sends warm air at full fan speed to the windshield. This is all a miracle to me, since none of these things has worked properly since I purchased the car (5 yrs ago).

The AC compressor still does not engage, which they tell me is due to a bad compressor speed sensor switch. Replacing the switch requires evacuating the system of freon, removing the compressor, etc. I can live without this 'til summer, I guess. Yes, it did occur to me that maybe the bad speed sensor switch was causing the problem with the system to begin with. But hey, what can you do?

Reply With Quote