View Single Post
Old 10-10-2002, 09:00 AM
pmizell's Avatar
pmizell pmizell is offline
Benz Zealot
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838
Not a problem Larry. p/n is 102 589 04 63 00 07. On how to use it, here's a blurb from a previous post.

Once you have the amp meter and harness Part #102589046300ks you can remove the air filter housing to locate the eha which is located on the back side of the fuel distributor. It is a small black box with a two pole wire connector on it. Your harness will plug into the vehicles harness and the eha. There will still be a third connector this is were the amp meter leads go. Make sure the positive lead of your meter goes to the solid black wire on the test harness. Turn the ignition on engine off and you should have a reading of around 19 mili amps. If this reading is ok start the engine and let it warm up to operating temp. You should see the amp meter moving back and forth across 0 amps. 0 amps is your mid point so you should have even movement on the negative and positive side of 0. If you do not have this reading you will need to adjust the lamda. This is done buy moving the screw down inside of the lamda tower, which is located on the left side of the fuel distributor. I believe it takes a 3mm allen to adjust it. If there is a metal ball in place on the top of the tower you will need to get a new lambda tower and break the old one off. Install the new one and make your adjustments. The new tower will come with another steel ball its up to you if you want to reinstall it. Once you have the lamda set correctly at idle you need to bring the rpms up to 2500 and the lamda readings shouldnt change within 15% of your idle readings. If it does you have further problems. Also while your doing this make sure the eha isnt leaking fuel they prone to do this after some years and mileage.
Good luck..
'01 E430, Sport 72,000 mi
'98 C280, 126,500 mi
Reply With Quote