View Single Post
Old 10-13-2002, 09:00 PM
kerry kerry is online now
Registered User
Join Date: Jan 2002
Posts: 17,490
center vent problem 85 300td

My center vents weren't working. After some troubleshooting I found a BB in the line from the third switchover valve. The previous owner must have thought the servo was bad and plugged the line. There was a leak but it was in the Y fitting just before the center vent actuator. I replaced that fitting. I can now pull a vacuum with my Mighty Vac on the line from #3 switchover valve and open the center vents. HOWEVER, when the ACC is in operation the center vents will not open unless I give the flap a little mechanical assist by lifting inside the vent or reaching up under the dash and pushing in on the vacuum servo arm. Once I initiate the opening process with my finger, the actuator will pull the flap open all the way and hold it open until the control calls for it to close.
Can anyone explain why this would be happening? Is that servo supposed to be picking up additional vacuum through the second line attached to that servo in order to open and it may not be getting additional vacuum from that line?

One has to wonder if Mercedes subcontracted out the engineering of the ACC to Lucas!
1977 300d 70k--sold 08
1985 300TD 185k+
1984 307d 126k--sold 8/03
1985 409d 65k--sold 06
1984 300SD 315k--daughter's car
1979 300SD 122k--sold 2/11
1999 Fuso FG Expedition Camper
1993 GMC Sierra 6.5 TD 4x4
1982 Bluebird Wanderlodge CAT 3208--Sold 2/13
Reply With Quote