View Single Post
Old 12-14-2002, 03:32 PM
xp190 xp190 is offline
Registered User
Join Date: Oct 2002
Location: Toronto, Canada
Posts: 700
Man my 190E SUX!

I had my 1985 190E 2.3 8vlv for 8 months now and I can't find what's wrong with it. It hesitates so much and it's getting worse from month to month, I spent so much time trying to figure out what it is cause I can't afford to take it to the dealer, any money I have I put into restoring it. This is what I have done so far to get it into resonable shape.

New timing chain, new sprockets, guides, tensioner.
New water pump.
New Spark plugs and wires.
New thermostat and tehrmostat housing will be put in in the next four days since right now I'm driving without one cause the housing cracked and it leaks like no tomrorow, so in order to plug the leak me and my mech took the the thermostat so I can drive my car to work.
I also got a new fuel filter in it, did a fuel system flush and it cured the hard starts but not the hesitation.

I check all electrical devices in it to control the engine, the MAF was off so I had to recalibrate it.

I think I'm missing the Fuel Pump relay cause the pump does not shut off after a few seconds of having the ignition off, and I can't find the part, what I thought was it turned out to be the whinshield wiper relay.

Here is what happens when I drive

When cold the car performs better, but once it heats up, it's terrible, it got worse after I put in the new timing chain, timing has been adjusted to 5 degree BTDC like it is supposed to be, if not please let me know and I will try something different.

From a stand still, in indle, I step on the gase and the rpm jumps up to 1500rpm like it should but betweek 1500 and 2000 instead of going up, it starts falling, this is at about 50% throttle. If I step on it harder, the engine stutters and shakes but does not go faster, after a little bit of this it will make a POP sound and jump up and take off like a rocket, this is most noticable in first gear, in higher gears it is not that noticiable. Highway driving is perfect, car has great power, it's just these damn take offs, the car crawls, and the popping I've been told is cause of bad timing, so that's why I had it adjusted but it's even worse now.

So what do I do? I'm running out of ideas and I love the car too much to get rid of it.

I also did some tests and it seems the the EHA is not getting the right current at take off to richen the mixture for the acceleratin. When the engine pops the current goes where it is supposed to be right away, and sometimes it slowly goes up.

Any ideas anyone?

All this info is probably useless to anyone who does not know exactly how the car works.

I need help, I don't want my 8vlv to suck anymore

Reply With Quote