View Single Post
  #5  
Old 08-08-2013, 11:23 PM
JamesDean's Avatar
JamesDean JamesDean is offline
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,034
Quote:
Originally Posted by jay_bob View Post
I vote Klima relay as well. If the rpm sensor on the compressor and the rpm sensor on the engine don't agree, the Klima locks out and will not reset until power cycled.

You do have a temperature cutout switch on the thermostat housing. However I believe that one self resets if the temperature drops to a safe level again.

I would look for the root cause as the Klima might be doing its job due to a belt problem. On the 603s with serpentine belt it is there to protect the rest of the engine systems from a locked compressor.
Hrmm. In this application its a 602 but I think the principle is the same anyway.

I've got a new belt on..maybe 2k miles on it.

I do know that I hear some groaning from something when the a/c is on... maybe it is causing belt slipping and speed differences? I'm not sure. Never did find out what was causing it.
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote