View Single Post
Old 04-04-2003, 05:44 PM
David C Klasse's Avatar
David C Klasse David C Klasse is offline
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
1995 C280 Electrical Problems

This is going to be a little lengthy... so here goes.

For the past few months, my mechanic has been telling me my battery is weak, but I had no symptoms, and a relatively new MB battery, so I brushed it off.
Starting 3 or 4 days ago, I would randomly notice my battery light (in the instrument cluster) was dimly lit... on and off... and as it got worse, the ABS light came on as well. Well finally last night, I was driving along, and noticed my headlights dimming.. then my radio turned off, then the power windows slowed, and the car died. If I waited about 5 min, it would barely restart, then shut off.
So I had MB RoadSide Assistance give me a new battery last night. Car has driven just fine since... however, the battery light is still dimly lit. My alternator is going south right?
Could this also be the reason my SRS code won't clear (dealer says it won't clear, so I need a new SRS module?).

I'm taking the car in Sun when I go out of town, so we'll see what happens... I just wanted a little heads up... I think alternator.

Thanks everyone!
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote