View Single Post
Old 05-11-2003, 12:53 PM
timroperco timroperco is offline
Registered User
Join Date: May 2003
Location: Cape Cod
Posts: 29
E 320 Cabriolet Electrical Gremlins

My 1994 E320 Cabriolet is suffering from several electrical glitches, and I'm hoping someone can advise me on how to track down the origin. Since this model of Mercedes was produced in relatively low numbers for just a couple of years, and has features that are not included on most Mercedes, I don't suspect there's a lot of accumulated knowledge, but any advice will be appreciated.

Problem #1: Crazy Seatbelt Retractor
Because this car is a convertible (drophead), a retractable seatbelt system was devised in which an arm moves forward out of a slot (mounted on rear seat wall) to offer the seatbelt once driver and/or frontseat passenger is seated. This system works perfectly on the driver's side, but displays some bizarre antics on the passenger side -- but only when passengers are absent (thus leaving the seatbelt disengaged).

When I go around a sharp curve or hit a bump, the passenger-side retractor arm suddenly starts moving back and forth, rapidly. Sometimes it moves forward to "offer" the seatbelt; pauses for a few moments; then slams back into the slot. The only way I can halt this behavior is to engage the seatbelt in its clasp, either with the passenger-side belt or using a clasp from one of the rear seat belts.

Clearly, there is some sort of sensor that needs to be replaced ... but I am not clear where it is located, or how to replace it. I would appreciate advice on how to detect, remove and replace this seatbelt retractor sensor.

Problem #2: Inoperable Brake Lamp -- "Third Tail Lamp"
A few months ago I noticed my "third lamp" does not work, neither as a brake lamp or running lamp. The regular fender-mounted tail lights, turn signals and brake lamps work perfectly. However, the "third lamp," which is mounted in the center of the trunk lid, fails to illuminate. Consequently, when I apply the brakes, the yellow warning light on the dash illuminates and stays on.

I removed the trunk lid liner and replaced all six of the small bulbs that are used in this lamp, but it still fails to light. Alll fuses appear in working order, but I am wondering if there is a connector that has failed, or if the wiring has somehow grounded out. Are there suggestions for tracing this wiring problem without completely disembowling the car?

Problem #3: Radio Antenna/Ground Problem
About six months ago, I noticed my rear-mounted (driver's side) retractable radio antenna mast had somehow become slightly bent; consequently, when I shut down the radio or car, the mast did not fully retract into the socket. Instead, about six inches of the mast remained raised. I have replaced such masts on BMWs before, and intended to buy a new mast, but kept forgetting to stop buy the dealer. About two months ago, the upper bent portion of the mast broke completely off, but this didn't seem to affect reception much.

However, a day or two after that portion of the mast broke, I went to start the car and it was as dead as a doornail -- no dash lights, buzzers or anything. Thinking I must have left a light or key on overnight, I placed a charger on the battery and the car eventually started. However, in driving the car about 10 miles, it became apparent the battery was draining away fast; warning lights began to come on and I could not use the radio, headlights, or heater (all needed, since I was driving in a snowstorm). If I revved the engine, I seemed to regain some electrical power --- sort of like and older car that runs on a generator instead of an alternator. In any case, after another mile or two, the car died entirely. A jumpstart from AAA did not provide enough juice, and eventually I had the car towed to a local service station mechanic who regularly services Mercedes.

He checked out the car and, as I suspected, both the battery and alternator had to be replaced. The battery was actually serviceable but, being the original and 9 years old, was in its last days. However, my mechanic's concern was with the alternator. When he installed the new one, it too started pulling amps and heated up, which alarmed him (and he's not a fellow easily alarmed). He ran a quick electrical check and decided the antenna retractor system was somehow at fault, grounding out somewhere along the line. He simply disconnected it and it has remained disconnected ever since; and I've had no further problems with the alternator. What's more, the radio actually works well on most local stations despite the lack of an antenna. However, I am still worried by what caused the antenna system to have such impact on the alternator.

Thinking that the broken mast may have something to do with the problem, I inquired at a nearby Mercedes dealer if they'd had any problems whereby water or snow had entered the antenna mounting hole (in the fender) and shorted it out; they reported none. I am understandably reluctant to replace the entire antenna retractor system if there is a ground fault or short somewhere else in the wiring that would cause a new system (or the new alternator) to burn out. Any suggestions out there on how to approach this problem?

Problem #4: While this may problem is listed last, I wonder if it also may be the source of all the above problems.

The passenger-side window on this car is slightly out of position when rolled all the way up or down. It's set about 1/4" too high; hence, when down it leaves about 1/4" of glass above the door line. And, if you close the door with the passenger window rolled all the way up, the extra 1/4" in height means the glass does not properly tuck or seat into the rubber weather strip along the top frame. This is easily remedied by rolling the window down slightly, after the door is shut, then rolling it back up to make it seat. But if I forget to do that, the resulting gap (along the vertical portion of the glass) lets some rain or snow enter the car when it is parked oustide. On a couple of ocassions, I have noticed the back seat carpeting has been damp.

Obviously, I need to have the window adjusted. Is this something I can do easily, or is it better left to a dealer? I've adjusted windows on other cars, but never attempted to open the door paneling on a Mercedes ... what tricks or secrets are involved?

Secondly, since the passenger belt system wiring (and, I suspect, the third lamp wiring) are all installed on the right (passenger) side of the car, could it be there's been significant wiring damage or corrosion from water that is causing all of these problems -- possibly the radio antenna problem, too? How would I go about removing the minimal amount of carpeting or interior panels to check?
Reply With Quote