View Single Post
Old 06-21-2003, 06:31 PM
2phast's Avatar
2phast 2phast is offline
Registered User
Join Date: Jul 2001
Posts: 613
Running EHA in FOM to fix hesitation?

Car is 1992 190E 2.6 (m103 motor)

Alright, heres my dilemmna.....

Bad hesitation upon acceleration, goes away at WOT or by feathering the accelerator. Idle is fine and this problem does not happen when engine is cold only warm/hot. As outside temp increases, problem gets worse. No problems with idle or starting (either hot or cold)

This is what I have done so far....

Replaced O2 sensor, plugs (correct OE plugs), plug wires, rotor, dist cap, replaced all vacuum lines (no vacuum leaks) adjusted air/fuel and checked OVP.

Problem is not related to these components, diagnosis keeps pointing to EHA unit so I unplugged it to run in FOM mode. I am aware that this will affect cold start and cause the car to run rich, but right now the car runs better than it ever has, hesitation is gone, acceleration is strong and gas mileage has improved. This confirms that EHA is either bad or is receiving incorrect signal, so...

What are the long term affects of running the EHA disconnected (FOM mode)?

Since I am having trouble finding the item that is causing the EHA to reduce fuel (assuming that the EHA is not defective), anyone have any concrete idea what else (other than the items mentioned above) that could be causing the hesitation?

I have searched this forum and read every post about hesitation and the EHA, nothing I have found provides solid answers. So far, the work I have done was justified as standard maintenance but I don't want to throw money at this problem.

These are the other possible items that could cause this problem, please feel free to add comments if you have experience with this items causing hesitation.

1. Coolant temp sensor (b11)
2. Throttle actuator
3. Air temp sensor
4. Defective EHA
5. Defective ECU

I am tempted to replace the coolant temp sensor, as its not that expensive but I have not found enough information about this item to really know if it could be the culprit. The Throttle actuator is quite expensive, so I definitely don't want to replace this unless I can pretty much ascertain if its the problem.

As for testing, I am not equipped to test the majority of this items but if we can narrow down the possible causes, I will drop the cash down at the local stealership for them to test these items.

thanks for the assistance.
1993 500E
Reply With Quote