View Single Post
Old 06-30-2003, 09:30 PM
Greg in Oz Greg in Oz is offline
Registered User
Join Date: Jan 2003
Location: Sydney, Australia
Posts: 627
Incompetent radiator shop in Oz too!

Some months back while rebuilding the water pump on my 350SLC I decided to have the slight leak in the radiator attended to. The radiator was returned (without protection on transmission cooler connections - grrr!) and refitted to the car.

Before long the radiator was again leaking from the same area. Again, I removed the radiator and returned it to the same shop to have it repaired and leak tested at no additional cost to me. On its return I was assured that the leak had been repaired. Again I noticed that despite me covering the transmission cooler ports, it was returned with them open. I spent considerable time flushing the cooler with transmission fluid and compressed air until no further creamy transmission fluid was evident. With the radiator reinstalled for the second time I test drove the car and all seemed fine, until the following morning when, you guessed it, there was a small patch of coolant under the car. Again, the radiator was leaking from the original area.

My dilemma is do I let the same incompetent shop have a third go at it (and again have to flush the trans cooler on its return), or do I find another radiator repair shop, spend more money and get who knows what sort of result? If the W107 radiator was not so expensive I would just buy a new one, as I fully intend to do with that in my 190E which also has a slight leak.
107.023: 350SLC, 3-speed auto, icon gold, parchment MBtex (sold 2012 after 29 years ownership).
107.026: 500SLC, 4-speed auto, thistle green, green velour.
124.090: 300TE, 4-speed auto, arctic white, cream-beige MBtex.
201.028: 190E 2.3 Sportline, 5-speed manual, arctic white, blue leather.
201.028: 190E 2.3, 4-speed auto, blue-black, grey MBtex.
201.034: 190E 2.3-16, 5-speed manual, blue-black, black leather.
Reply With Quote