View Single Post
Old 10-11-2003, 10:48 PM
Djenka Djenka is offline
Registered User
Join Date: Oct 2003
Location: South Africa
Posts: 21
450SLC after years in the garage runs roughly

I have posted tis at SL forum but realised this is more appropriate place:

Recently got my self one fine example of 1980 450SLC Euro specs with 49500km (~33Kmiles), full house, original "virgo intacta" condition.
Engine has very bad start (takes more than 10seconds of cranking to start) and once started it will run very rich for a while with bad missing. Shortly, engine will run more or less fine with occasional missing. Once started engine, tekes a split second to restart. A 10 minutes pause will cause another long kranking to start.
As the simplest remedy, i've changed fuel and air filter, spark plugs and did minor engine service (oil, filters). Furthermore, i had replaced very bad (stiffened) rubber seal on injectors and O-rings on their plastic sleeves. That seemed to improved idling but after adjusting CO2 to specified levels (without air filter installed) the overall performance of engine improved significantly. Unfortunatley, all the original problems stayed there but with much shorter period before normal-like operation of engine.

Now, with everything being 23yrs old i just don't know where to start.
Coil? Electronic ignition? Spark plug cables and distributor? Temperature sensors? Cold start valve? Suplemetary air valve? Intake manifold gaskets? Vacuum line...
The list is big and if i start to replace all one by one it'll cost an arm and a leg.
Where to start, what to do first?

(Note: car is 107024 with engine 117985 and no emission control devices)
Reply With Quote