Thread: ESP problem?
View Single Post
Old 11-13-2003, 03:53 PM
ML Dude's Avatar
ML Dude ML Dude is offline
Registered User
Join Date: Mar 2001
Location: Southern California
Posts: 373
ESP problem?

Any reports about ESP malfuntion and how to identify and correct it? Specifically, my ESP light comes on and sometimes the ESP brakes the truck and impedes my advance, this always happens when moving from a standstill.

Unfortunately it's intermittent. The dealer has replaced the BAS/ESP brake switch and a transfer motor in the transmission (I think) on separate service calls. The last time there were codes which lead to the transfer motor swap. The problem persists. Also, I burned through a set of brake pads after 10K miles, no load no crazy braking. Now on the last check they say nothing found, but the brake wear is down to 50%, 18K on the odo. They say the brake wear is normal, I say look at my tires which aren't worn and look like they'll go 50K miles.

Subjectively, if I turn off the ESP, the truck feels peppier...any suggestions on how to proceed analyzing the ESP operation would be appreciated!

Rgds, Ed
Ed "Don't Benz's just feel better..."

Current wives...
2000 ML430 Skyview "The Mel"
2000 CLK430 Cab "The Cab"
85 300D Turbo "The Diesel"

Past wives...
92 300E
85 190E

"One should as a rule respect public opinion in so far as is necessary to
avoid starvation and to keep out of prison, but anything that goes beyond
this is voluntary submission to an unnecessary tyranny, and is likely to
interfere with happiness in all kinds of ways."
Bertrand Russell
Reply With Quote