View Single Post
Old 02-08-2001, 10:01 PM
David C Klasse's Avatar
David C Klasse David C Klasse is offline
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
To those of you that have been following my posts, and others: Damn Check Engine light came on again yesterday (maybe it'll burn out soon and I wo'nt have to worry about it!). I am assuming that it's the 02 sensor again. The code was cleared the day before, and went away minutes later, but is back on. COuld the O2 sensor be working intermittently? Or was it because the error was cleared, then registered again in computer? ...which seems like most plausible explanation.
Another twist is that the check engine light came on last night when the ambient temp was about 45 degree F. I had heat on full and was driving about 50 mph. Well the Check Engine Light came on at this time, and the engine temp was well below the 80C, but had already been warmed up to operating temperature, and when I had the heat on and driving and cool air must have cooled engine down. 1. Is engine temp supposed to go that low, even with heat and cool air around? and 2. The check engine light went on when engine was below 80C, could this be a correlation to the 02 sensor registering as bad in comp?? Hope I didn't lose anyone on this! Thanks again to you all!
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote