View Single Post
Old 04-25-2001, 12:40 AM
David C Klasse's Avatar
David C Klasse David C Klasse is offline
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352

Hi David:

Thank you for your response. I really appreciate it.

I have 102,000 miles and climbing. I will support the partshop here too!

The headrest switch doesn't work at all even while the engine is running. Minor problem since I like rear headrests.

The heating problem is a bit of a concern but I can deal with that. I need to get on that one as soon as possible. Water Wetter is made by Redline and a friend works there so I already have that in there.

The engine pings while under load conditions. The plugs look fine, I am wondering if it is due to the heat problem? Not too sure about that one.

Once again, Thank You for your response.

Etsa, I did this so that this info can be stored in the data base for later use!!

Etsa, then definitly change the coolant and thermostat. Hopefully that will resolve your problem. What area are you in? How hot does it get?

You say the ENGINE pings... hmm, maybe someone else could help you out? Are you using 91 or higher Octane?

Hopefully there is a way to get the headrests down manually?

Good luck and let us know how it works out. Also, you posted twice, I would erase the other one!!
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote