View Single Post
Old 06-18-2001, 07:16 PM
David C Klasse's Avatar
David C Klasse David C Klasse is offline
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
THanks for the help. I already put the wheel back on, so I'm probably just going to forget it. I removed the wheel earlier and and checked everything (even removed that one screw!), rinsed it all, but I just don't know really how or what to look for. Everything looks "ok" to me, but I'm not a tech and don't know for sure.
What's frustrating is that I took it to my mechanic, he can't hear anything! I'm going to take it back agian tomorrow, have them remove the wheel, check the wheel bearings, have them retorqued if needed, and check the upper and lower ball joints.
BTW, it has 90K miles, and I don't think the shocks are a problem.

Nonetheless, I have a few pictures to post.

The peice at the bottom is the upper ball joint, correct? Bigger pic below.

And what is this? Is this anything that I should check?

This is probably all pointless, I'm just going to take it in tomorrow and see what they can do. Alteast I tried!
What do you think the prices on these parts are? Thanks guys.
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote