Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Regional Forums > Good MB Shops > Canada

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-31-2015, 02:47 PM
Registered User
 
Join Date: Aug 2015
Location: Omemee on canada
Posts: 1
Siek's 1987 Mercedes.

William Buwalda <williambuwalda@gmail.com>
2:31 PM (25 minutes ago)

to PeachParts
I am having problems with my Mercedes 1987 / 300d engine. I'v replaced the injection pump and it will start but there is no power. One of the injectors is showing no difference to the running of the motor, all others do. I'v checked the filters, new fuel pump but no power. It will not idle fast enough to ever get me going . What ells can i do. The tank has been cleaned out and also all the lines. Do I have to take a compression test and how would I get one of those testers. A tractor place perhaps.
Siek.
Reply With Quote
  #2  
Old 09-01-2015, 05:03 PM
Registered User
 
Join Date: Oct 2012
Posts: 4,727
Post your problems on the diesel site. Few read the Canadian section.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page