Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-31-2004, 05:19 PM
Registered User
 
Join Date: Sep 2004
Posts: 57
500E factory stereo gone quiet

I have a 92 500e with the factory Becker Mexico withautochanger. Unfortunately the sound has disappered although the unit seems to be working fine,It was intermitent for a week before stopping altogther.

Does anyone know what may have happened?

I'm going to try removing and cleaning the fader. I want to locate the amplifier does anyoneknow where it will be?

I need helpl!!!

Thanks

Tobyd10

__________________
tobyd uk
94 E280T
Reply With Quote
  #2  
Old 11-01-2004, 05:25 PM
Ashman's Avatar
Registered User
 
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,749
perhaps it is the factory amp that is going south or has gone south. it's probably in the trunk.

Alon
__________________
'92 300CE - Sold
2004 C240 - 744 - C7 Wheels - Android Radio
2002 C320 - 816 - Sport Wagon
Reply With Quote
  #3  
Old 11-07-2004, 09:33 AM
Registered User
 
Join Date: Sep 2004
Posts: 57
I think the AMP is faulty - does anyone know what model it is so I can look at getting it replaced.
__________________
tobyd uk
94 E280T
Reply With Quote
  #4  
Old 11-07-2004, 04:21 PM
La Jolla Audio
 
Join Date: Dec 2001
Location: San Diego California
Posts: 996
I would bet it isn't the amp as there are two amps in the system one for the left side and one for the right side. The problem would be most often found in the tuner module in the trunk on the right hand side behind the trim panel behind the amplifiers. The model # is 1432 and if you want we have a repair business at www.mercedesradiorepair.net and we stock rebuilt units for exchange.
__________________
The Mercedes Specialists Since 1986
Reply With Quote
  #5  
Old 11-08-2004, 03:52 AM
Ashman's Avatar
Registered User
 
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,749
Thats what I meant scott thanks for clearing it up that box int he trunk on the right.

Alon

__________________
'92 300CE - Sold
2004 C240 - 744 - C7 Wheels - Android Radio
2002 C320 - 816 - Sport Wagon
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page