Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-21-2004, 10:45 PM
Registered User
 
Join Date: Nov 2004
Posts: 20
Bose system in a 95 R129 SL500

I think that the 7 channel Bose amp in my SL may be on its way out.

The sound is not very good - very dull, no highs, no lows, etc... Also, the passenger side is noticably louder, and one of the driver's door speakers does not seem to work.

Given all the previous messages to this board and others, I strongly suspect the amp, but would like to know what else I can check before I invest the $$ and find it was the head unit or tuner.

If it is the amp, how advisable is it to get a replacement from a dismantler? The unit would come with a 100 day warranty, and cost about half as much as rebuilding my unit.

Also, my car does not have the CD now, but I found the wires in the trunk. How would a CD player be secured in there, and what is your opinion of purchasing a unit from Crutchfield advertised as being compatible?

Thanks in advance,

Robert
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page