Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-22-2007, 02:27 PM
Registered User
 
Join Date: Sep 2007
Posts: 4
Unhappy 1991 190E Radio Replacement Help

Before i get flamed, i've searched all over the place, i have found the wiring diagram pictures (u kno, the ones so blurry they hurt your eyes). i've found the listing of the wire colors and still have an issue...

first off, the original radio only sent static, and that was only if the volume was all the way up and the fader was spun all the way forward

i pulled out the original and saw a horrifying wiring job.. apparently the person who had the car before my girlfriend messed it up big time. here are the wires:
  • a large AT-Keyboard looking plug with a white sleeve
  • a single round plug with a black sleeve over a yellow/black wire
  • an extended molex connector with 6 spots. some of these spots have 2 wires going into it (from what i've found, this may be alarm related)
  • a 4 prong molex style connector (i've already gotten these run, they were power, ground, accessory, and ant(or amp) power)
  • a single black connector (this is spliced off of the ground)
  • there is another loom that just has red and yellow that is spliced into the respective wires
  • two component looking wires, one black, one white. the inside prong is round, but instead of having a surround on it, it has a flat 'spade' on the side. the wires coming off of this are brown/brown-red & brown/brown-black.
i have the power wires hooked up just fine, but i cannot figure out which wires are for the speakers. i've read many people talking about bypassing the fader (which i'm completely up for) but i have no idea what the wire assignments are in there (which wires go to which speakers, etc).

Please please help... i'm at the point that if i can't figure it out by tonite, then i'm just going to put the old one back in and sell the beast.
Reply With Quote
  #2  
Old 10-22-2007, 04:11 PM
Registered User
 
Join Date: Sep 2007
Posts: 4
just an update: the head unit i am trying to put in has pre-amp outs for the rear speakers (dunno if i could use those). and the car is equiped with the phone antenna and wires.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page