Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-28-2007, 03:20 PM
Registered User
 
Join Date: Jul 2007
Location: georgia
Posts: 20
radio problems

any one out there have problems with the becker radios? i replaced the speakers with jbl's. sounded great for 2 weeks. then left side returned to the sound the original speakers had. snap crackle and low volume. i removed the speaker and tested with another and still pretty much have the same problem. it seems like the signal from radio is the culprit. any suggestions. iwould love to keep the car original.
Reply With Quote
  #2  
Old 10-28-2007, 03:48 PM
Registered User
 
Join Date: Mar 2003
Location: Milwaukee Wisconsin
Posts: 1,150
Which model? Some have amplifier built into head unit, others have seperate amps. A number of shops repair the Becker's ( www.beckerautosound.com ) and LaJolla Audio. But most of us have replaced original units with aftermarket units like Alpine or Blaupunkt. Essentially, connections go bad between amp and speakers or between amps and head unit. Sometimes parts inside amps get loose due to solder fatigue.
__________________
Resistance is Futile.
Reply With Quote
  #3  
Old 10-28-2007, 04:46 PM
Registered User
 
Join Date: Feb 2003
Location: roslyn, LI,NY
Posts: 445
becker radio s--ks

I had Mexico in my 450 sl 1977. Spent $149 to repair at Beckers in NJ, Waste of money! replaced with a Sony cassette installed for $80. Excellent radio and player! Your choice. good luck, Abe G PS fits perfectly.
Reply With Quote
  #4  
Old 10-30-2007, 05:45 PM
Registered User
 
Join Date: Aug 2007
Posts: 15
Becker Output

I've had a similar experience with my Mexico until I switched to other final amps, (Profiles- Crutchfield) one for front and rear speakers, and a mono for a homebuilt under rear storage area 10" subwoofer. It sounds great now and has a very tube-like sound. The FM alignment in these was never good, but I ususally feed it with my Treo/iPod. I don't know when I tried a cassette, it's always been hungry for Bert Kaempfert tapes!
Reply With Quote
  #5  
Old 11-01-2007, 02:43 PM
Registered User
 
Join Date: Sep 2007
Posts: 30
this is a common problem with Becker's - but you may actually have an Alpine - looks identical to the Becker - and were put in SLs for the 94 and 95 years.

In future - please tell us what kind of car you have.

W
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page