Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-24-2007, 06:13 AM
Registered User
 
Join Date: Sep 2007
Posts: 119
Kenwood KDC-7007 - CD won't come out

Posted this on the Audio forum - not takers yet so I'll try my luck here.

Anyone got one of these units? The front is supposed to swing open (not sure how, has never worked since i got the car in September) but nothing happens when i hit the eject button - Elvis was good to listen to for the first month or two, now I'm looking for a little variety!
__________________
'87 BMW 325 convertible (162k + miles)
'87 300E, 144k + miles (sold)
'93 Chevy Blazer (full size), 207K + miles
'89 Sea Ray 390EC, 2 x 454's, 1550 hours...
'85 AMF Sunfish

Olde Towne Portsmouth, VA
Reply With Quote
  #2  
Old 11-24-2007, 01:28 PM
vtxflyer's Avatar
Junior Member
 
Join Date: Sep 2007
Location: Whitewater, WI
Posts: 38
I found this for you. I hope it helps.

http://www.kenwoodusa.com/Support/Car_Entertainment_Owners_Manuals/

Just type in your model # and it will give you the owners manual.

Sam
__________________
1987 300E
1972 220d
2004 Dodge Ram 2500 T/D
1997 Explorer
1999 F250 V10 Guzzler
2002 Honda VTX 1800

2003 Boxer Named Sir Lancelot (Lance)

Reply With Quote
  #3  
Old 11-24-2007, 08:48 PM
Registered User
 
Join Date: Sep 2007
Posts: 119
Thanks Sam - I think there is something wrong with it so I'll contact Kenwood to see if there's a fix!
__________________
'87 BMW 325 convertible (162k + miles)
'87 300E, 144k + miles (sold)
'93 Chevy Blazer (full size), 207K + miles
'89 Sea Ray 390EC, 2 x 454's, 1550 hours...
'85 AMF Sunfish

Olde Towne Portsmouth, VA
Reply With Quote
  #4  
Old 11-25-2007, 07:36 PM
Registered User
 
Join Date: Feb 2007
Posts: 173
Ribbon Cable

kenwood has an on going problem with the ribbon cable on the flip face units. I had the KDC 617 which shares the same design as the 7007 and had to have it replaced under warranty and then serviced twice before I tossed it out the window on the PA Pike when it died for the last time.

The problem is the movement on the cable causes the contact teeth to wear away the copper on the ribbon and the unit goes into DOA default mode. They are a hassle to open and get to the cable with the face folded in place and Kenwood wants 2/3rds the cost of a new unit to repair out of warranty.

I bought a used alpine in ebay and it works, matches my 300E interior (Grey) and was under the repair cost for the Kenwood.

Kenwood USED to make good car head units but since they went "ghetto/gofast" the quality just isn;t there. too many gee wiz multi function buttons and chinese budget guts...

I don;t have an ipod, a rio or an XM/Sirius and all I want is basic buttons and one big knob that makes it go louder!
Reply With Quote
  #5  
Old 11-25-2007, 07:49 PM
Registered User
 
Join Date: Sep 2007
Posts: 119
Well I did send the same question to Kenwood and if they confirm that the teeth are likely worn, I'm either stuck with Elvis for the long haul or I need to swap out the unit.

Its been a very long time since i installed a stereo...are all the connectors standardized these days? Can I pop out the old Kenwood and plug in any other manufacturer's unit or is that just wishful thinking?
__________________
'87 BMW 325 convertible (162k + miles)
'87 300E, 144k + miles (sold)
'93 Chevy Blazer (full size), 207K + miles
'89 Sea Ray 390EC, 2 x 454's, 1550 hours...
'85 AMF Sunfish

Olde Towne Portsmouth, VA
Reply With Quote
  #6  
Old 11-26-2007, 11:53 PM
vtxflyer's Avatar
Junior Member
 
Join Date: Sep 2007
Location: Whitewater, WI
Posts: 38
Go on ebay and pick up another Kenwood. They are really cheap $$! I am going to get one soon, as the ol Becker just doesn't have enough modern devices. (ipod, sirius, etc.) Also, I have seen stereos pretty inexpensive at Walmart, quality brands too...............go figure. If you get another Kenwood, I would think it would be a plug and play................
__________________
1987 300E
1972 220d
2004 Dodge Ram 2500 T/D
1997 Explorer
1999 F250 V10 Guzzler
2002 Honda VTX 1800

2003 Boxer Named Sir Lancelot (Lance)

Reply With Quote
  #7  
Old 11-28-2007, 09:20 PM
Registered User
 
Join Date: Feb 2007
Posts: 173
Source for head unit wiring harnesses

Try this guy in Texas. http://www.installer.com he seems to have all the chassis and head unit connectors and will deliver a soldered up harness if you want.

Quote:
Originally Posted by raysea390 View Post
Well I did send the same question to Kenwood and if they confirm that the teeth are likely worn, I'm either stuck with Elvis for the long haul or I need to swap out the unit.

Its been a very long time since i installed a stereo...are all the connectors standardized these days? Can I pop out the old Kenwood and plug in any other manufacturer's unit or is that just wishful thinking?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page