Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-23-2008, 12:23 PM
bpeters2's Avatar
Registered User
 
Join Date: Mar 2006
Location: NW Indiana
Posts: 198
Stuck antenna blowing fuse??

I keep blowing the fuse which powers my radio. At the same time my antenna seems stuck (it usually goes up and down as you turn on/off radio). Is it possible/likely that a stuck antenna could be blowing this fuse. Are the radio and antenna on the same circuit. My car is a 85 300td. Thanks

Brett
__________________
'85 300td Frybrid WVO Kit
Reply With Quote
  #2  
Old 01-23-2008, 12:49 PM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 26,334
is there a switch on your dash for raising the antenna? turn it off and see if the radio fuse still pops...
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #3  
Old 01-23-2008, 01:56 PM
rrgrassi's Avatar
mmmmmm Diesel...
 
Join Date: Jun 2006
Location: Royse City Tx
Posts: 4,872
An eletric motor that cannot turn draws a lot of amps, gets really hot and then acts like a direct short, which blows the fuse. Do the test VS suggested.
__________________
RRGrassi


70's SPM #5608 Fairmont A-4 MOW car

06 VW Jetta TDI 210K miles

03 VW Golf TDI 5 speed 372K Miles

RIP--Lost in fire...82 300D 322K was My Daily Driver-On the search for a w126 now...

90 Dodge D250 5.9 Cummins/5 speed. 350K
Reply With Quote
  #4  
Old 01-23-2008, 02:39 PM
Phil's Avatar
Registered User
 
Join Date: Dec 2004
Location: Sonoma County, California
Posts: 1,064
I have found that a lot of these antennas get water in them, if you remove the cover on it you'll be able to tell if its full of water and shorting out the motor.
__________________
1983 300SD
200000miles
Reply With Quote
  #5  
Old 01-23-2008, 09:03 PM
mobetta's Avatar
(Oo{-I-}oO)
 
Join Date: Mar 2006
Location: minnesota,hey.
Posts: 1,840
mine was drawing 9 amps and running the batt. down while parked, but not blowing the fuse. definitely possible.
__________________
1984 123.193 372,xxx miles, room for Seven.

1999 Dodge Durango Cummins 4BTAA 47RE 5k lb 4x4 getting 25+mpgs, room for Seven.
Reply With Quote
  #6  
Old 01-23-2008, 10:03 PM
bpeters2's Avatar
Registered User
 
Join Date: Mar 2006
Location: NW Indiana
Posts: 198
Not the antenna..Checked the fuse diagram and the antenna isn't on the blowing fuse's circuit. Think I figured it out though...long story.
__________________
'85 300td Frybrid WVO Kit
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page