Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-12-1999, 12:43 PM
Bing
Guest
 
Posts: n/a
I have a '91 420 SEL. Whenever I turned on my M/B Radio and listen to FM station all of my right side speakers do not work. But when I listen to AM station all speakers left and right work. The speaker balance seems OK. At times, when I run into a bumpy road all speakers would work with FM station and then the right speakers won't work again. Does anybody encoutered this problem? Thank you in advance for your help.
Reply With Quote
  #2  
Old 07-12-1999, 01:52 PM
300CE-24
Guest
 
Posts: n/a
I have the same problem with the Becker Grand Prix 1432, a technician from Becker of North America suggests the amplifier in the trunk probably needs repair or replacement. http://www.beckerautosound.com/

------------------
Albert
91 300CE
Reply With Quote
  #3  
Old 07-12-1999, 08:52 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
On the 420 it could be the amp in the rear behind the rear seat or the head unit.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Reply With Quote
  #4  
Old 03-29-2000, 12:05 PM
emmy
Guest
 
Posts: n/a
I am working on my radio, and it seems like I have more questions for each answer I receive.

I bought a 91 560SEL with a becker 754 installed and working. I would like to install back the 1432 which was originally on the car. I have the 1432 head unit and the tuner/amp installed in the trunk.

A message on this tread suggest that there may be amps for each rear speakers installed somewhere behind the rear seat of the car. can anyone comment on this possibility? Was this standard for a 1432 set-up? I know about the tuner/amp installed in the trunk, but do not know anything about additional amps for each of the rear spekers.

Also, how would I wire the 6 speakers ( 2 Fronts, 2 front doors, and 2 rears) with the Fader control?

tia
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1992 500SL ASR Problem jrodnar Mercedes-Benz SL Discussion Forum 10 12-22-2008 11:18 AM
1992 500SL ASR System Problem jrodnar Mercedes-Benz SL Discussion Forum 3 04-05-2003 02:34 PM
Intermittant radio problem jude Car Audio and Multimedia 2 07-02-2002 07:48 PM
300SDL radio swap and alarm problem John Winn Car Audio and Multimedia 0 05-20-2001 11:29 PM
Radio Problem LKirksey Car Audio and Multimedia 1 04-26-2000 08:50 PM



All times are GMT -4. The time now is 02:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page