Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-12-2014, 09:21 PM
Registered User
 
Join Date: Feb 2003
Location: shelby, nc
Posts: 35
1991 350SDL Radio

Radio will power up and accept the code and will seek and tune but no sound from the speakers. Could this be an amplifier problem? All fuses are fine in the fuse box. Does the amp have a fuse of it's own? Where is the amp located?
The radio was removed when the evaporator coil was replaced, has not worked since. Thanks
Reply With Quote
  #2  
Old 03-19-2014, 06:31 PM
Registered User
 
Join Date: Apr 2009
Posts: 256
Are you certain that all connectors were re-attached? I recently installed mine and one of the spade connectors kept the radio from making any sound. Just like you are describing. Otherwise, the fuse that controls the amps. I have a hard time believing that both amps went bad at the same time.
Reply With Quote
  #3  
Old 03-19-2014, 06:38 PM
compu_85's Avatar
Waiting for his Model 3..
 
Join Date: May 2008
Location: Springfield VA
Posts: 5,174
The amps are located behind the rear seat. Are you sure you got the large gray data cable plugged in completely?

-J
__________________
1991 350SDL. 230,000 miles (new motor @ 150,000).

2013 Fiat 500E. 20,000 miles, 80 miles at a time.
2012 Passat TDI. 95,000 miles. More space, power, and fuel economy than the Benz
2004 Touareg V10 TDI. 150,000 miles. One of 450.
1999 Jetta TDI. 310,000 miles.
1992 Jetta ECOdiesel. 156,000 miles. 1 of 48. Sold.
1991 Jetta ECOdiesel. 430,000 miles. 1 of 700. Sold to VeeDubTDI, totaled in front of our house
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page