Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-05-2014, 11:33 AM
Registered User
 
Join Date: May 2014
Posts: 3
300sd w116 Becker Mexico Stopped working on pressing auto seek

Hi All,

Have had our 300sd a few weeks now. The radio was working great, actually pretty impressed by the reception and quality of audio for 1970's technology!

We were driving last night and accidently pressed the "auto seek" button (which I didn't even know that is what it was until I checked in the manual what that middle button did!). Anyway.. pressed it and the radio cut out and won't turn back on!

Has anyone experienced this? It is almost like a fuse has gone and it has lost all power, but can't see any blown. I can't find anything similar on the forums :s
Reply With Quote
  #2  
Old 05-05-2014, 02:28 PM
Registered User
 
Join Date: May 2014
Posts: 3
Problem solved, inline fuse on the power to the radio, hidden behind the unit. Doesn't look original, but fused replaced and radio is back on.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page