Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-23-2014, 08:40 PM
Registered User
 
Join Date: Apr 2000
Location: Location:Las Cruces NM. USA
Posts: 79
Radio inoperative after battery change

The battery died in my 2009 E350 and after replacement the radio is not working, the Nav is working properly but it had Device Unavailable on the screen when the radio was selected. We drove the car for a while and the unit now shows please wait. It is charging at 13.98V and everything else seems to be working correctly. What can I do to correct this?
__________________
Dave
88 300E 250K Sold
2000 C230K Totaled @104K
2003 ML320 140K Sold
2009 E350 4Matic Sport 46K Sold
2011 ML350 60K Sold
2014 GLK350 40k
Reply With Quote
  #2  
Old 06-25-2014, 08:31 PM
Registered User
 
Join Date: Apr 2000
Location: Location:Las Cruces NM. USA
Posts: 79
Problem solved. Disconnected the battery for about 1 minute and that fixed it.
__________________
Dave
88 300E 250K Sold
2000 C230K Totaled @104K
2003 ML320 140K Sold
2009 E350 4Matic Sport 46K Sold
2011 ML350 60K Sold
2014 GLK350 40k
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page