Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-21-2015, 09:08 PM
renaissanceman's Avatar
Registered User
 
Join Date: Nov 2014
Location: Central CA
Posts: 795
1987 300D Becker Radio AM/FM troubleshooting

I have the original Becker Radio, and it works (and sounds) great using a tape adapter to play audio from my iPod. Real tapes do not play correctly, however. I think the tension is probably screwed up.

The FM/AM is non-functional, as is the antenna. I don't know the first place to start. Anyone have any pointers on where to start on getting the system funcitonal?
__________________
RenaissanceMan Labs: where the future is being made today.

Garage:

2005 Volvo S40 T5 AWD, 77k
1998 Saturn SL2, 244k - 35 mpg (gone, never forgotten)
1987 Mercedes-Benz 300D turbodiesel, 4 sp auto, 156k - 28.7 mpg
1993 Tracker 4x4, 2 door, 8v, 3 sp auto. 134k - 25 mpg
1996 Tracker 4x4, 2 door, 16v, 3 sp auto. 110k - 28.6 mpg

WARNING: this post contains thoughts that may be discovered by the state of California to cause cancer.
Reply With Quote
  #2  
Old 03-22-2015, 12:02 AM
Banned
 
Join Date: Feb 2015
Posts: 112
Do a search about the proper procedure for dealing with that radio, if it is disconnected from power under certain circumstances it will go into a sort of lock down mode that requires a reset that only the dealership has the proper code tool needed for a reset. There is no aftermarket tool available anywhere, some dealerships no longer have the tool either. the radio's in model years 86 and 87 for sure but maybe a year or two later as well.
Reply With Quote
  #3  
Old 03-22-2015, 12:21 AM
renaissanceman's Avatar
Registered User
 
Join Date: Nov 2014
Location: Central CA
Posts: 795
The head unit seems to operate, and can play music through a tape adapter, but the AM/FM is off. Is that the symptoms of being locked out?
__________________
RenaissanceMan Labs: where the future is being made today.

Garage:

2005 Volvo S40 T5 AWD, 77k
1998 Saturn SL2, 244k - 35 mpg (gone, never forgotten)
1987 Mercedes-Benz 300D turbodiesel, 4 sp auto, 156k - 28.7 mpg
1993 Tracker 4x4, 2 door, 8v, 3 sp auto. 134k - 25 mpg
1996 Tracker 4x4, 2 door, 16v, 3 sp auto. 110k - 28.6 mpg

WARNING: this post contains thoughts that may be discovered by the state of California to cause cancer.
Reply With Quote
  #4  
Old 03-22-2015, 11:13 AM
renaissanceman's Avatar
Registered User
 
Join Date: Nov 2014
Location: Central CA
Posts: 795
Looks like it is a Becker 754. I am not having the 4 dash issue (yet).

The issue is no reception on AM/FM and no antenna operation or even a noise to make me think it is trying to extend.
__________________
RenaissanceMan Labs: where the future is being made today.

Garage:

2005 Volvo S40 T5 AWD, 77k
1998 Saturn SL2, 244k - 35 mpg (gone, never forgotten)
1987 Mercedes-Benz 300D turbodiesel, 4 sp auto, 156k - 28.7 mpg
1993 Tracker 4x4, 2 door, 8v, 3 sp auto. 134k - 25 mpg
1996 Tracker 4x4, 2 door, 16v, 3 sp auto. 110k - 28.6 mpg

WARNING: this post contains thoughts that may be discovered by the state of California to cause cancer.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page