Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-25-2015, 04:05 PM
H-townbenzoboy's Avatar
Now Y2K Compliant
 
Join Date: Jul 2003
Location: Houston, TX
Posts: 4,200
Installed Kenwood HU in 81 300SD, now ashtray won't reinstall

I purchased a new Kenwood HU and the proper Metra wiring harness from Crutchfield last week and went to install it in my 1981 300SD. I got everything wired up and used the provided DIN cage, but I have a problem buttoning everything up. I can't slide the ashtray back in because the tabs that held the old Becker in are in the way. I tried pushing them back up, but they can't go back up into their recesses because of the new headunit and DIN cage being in the way.

Any thoughts or suggestions on how to remedy this?
__________________
Current Vice-President of MBCA|Houston

81 MB 300SD, 82 MB 300D Turbo (sold), 04 Lincoln Town Car Ultimate

Sooner or later every car falls apart, ours does it later!
-German Narrator in a MB Promotion Film about the then brand new W123.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page