Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-03-2016, 10:28 PM
Registered User
 
Join Date: Oct 2016
Posts: 1
why all these trouble and how to fix please

mybenze is 2004 c class w203 done only 50 k kilometers.German made

all these faulty signals are coming

faults
Restraint system Service SRS
Electronic stability programme(ESP) not available
Brake assist(BAS) not available

Anti-lock brake system(ABS)
check Front left park light BUT LIGHT S WORKING WELL
CAR IS MOVING WELL
Reply With Quote
  #2  
Old 10-04-2016, 07:00 PM
Administrator
 
Join Date: Mar 2016
Location: Los Angeles, CA
Posts: 1,615
Sorry that you're having these troubles lali:

Restraint system Service could be something tiny with the fuse. Stability issue may also be a fuse or a blown suspension component. Does the car feel 'bouncy' when driving? Brake assist light could be a number of things. Sorry that my response is so open-ended. Best of luck!


-Dmitry
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page