Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-25-2002, 02:56 PM
Registered User
 
Join Date: Jul 2002
Posts: 2
Unhappy confused about E320 wagon audio

Hello!
I've been searching the archive looking for answers but remain confused. The sound on our '94 E320 wagon has degraded into little more than a low static. From what I can tell I have a stock Becker head with a small amp in the back. There are two dash speakers, two subs in the front doors and two speakers in the rear doors.
First, can anybody tell me how I might explore to see if my problem is simply a shorted-out wire, loose connection or some other fixable solution?
Second, if the diagnosis turns out to be a bad tuner, amp, or speaker(s) can I swap out that item(s) without overhauling the whole system?
Obviously, I'm looking to save money here. Any comments will be much appreciated.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page