Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-02-1999, 03:04 PM
Registered User
 
Join Date: Mar 1999
Location: Vienna, Virginia, USA
Posts: 36
It abruptly froze 1/3 of the way up last night. I see Benzes with stuck antennae like this on the road all the time -- is this a common problem? Any idea what causes it before I start pulling stuff out and checking voltages?
  #2  
Old 07-02-1999, 05:55 PM
Senior Member
 
Join Date: Apr 1999
Location: Walnut,CA,USA
Posts: 554
Clean you antenna with WD40....and check is the antenna switch on all the way position
not the half position (if you have antenna switch).
hope this help

------------------
MB STARS Master Guild Technician,12 years MB tech
5 years independent shop owner
  #3  
Old 07-02-1999, 06:04 PM
moraine
Guest
 
Posts: n/a
A good practice to get into is wiping your antenna everytime you fill-up your car with fuel.

I have purchased and use antenna wipes. Each package is about 1.5" square and when you tear off opposing sides, you can slide the whole packet over the extended antenna and repeatedly wipe it up and down. I believe that the "moisture" in the wipe is merely isopropyl alcohol. It is remarkable how dirty an extended antenna can get and that dirt can certainly affect the antenna's proper functioning.

I'm not sure if WD-40 is sticky enough that it may attract dirt while extended. As for the alcohol, it'll evaporate quickly and leave the antenna dry.

Good luck-

Terry
  #4  
Old 07-02-1999, 10:02 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
A bent mast will cause this. Just grab the bottom of the mast and rotate...you will see if it is bent. If so replace it. The mast can be bought seperately from the motor and is easy to install.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #5  
Old 07-04-1999, 10:57 AM
Registered User
 
Join Date: Mar 1999
Location: Vienna, Virginia, USA
Posts: 36
Thanks for the help. I think it's an electrical or mechanical problem, not a dirty or stuck mast. It has always worked smoothly before. It can't be raised or lowered by hand, although it moves slightly then bounces back to the same position when really pressed. Seems to me that the gears or motor is frozen in place.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Hirschmann Power Antenna Holson Adi Mercedes-Benz Used Parts For Sale & Wanted 1 05-30-2002 09:17 PM
Power antenna to radio wire KNanthrup Car Audio and Multimedia 4 03-30-2002 02:23 PM
Power antenna to radio wire KNanthrup Car Audio and Multimedia 6 03-26-2002 10:09 AM
Problem with radio power antenna on 97 C280 Ali Al-Chalabi Car Audio and Multimedia 3 01-15-2002 11:47 PM
Power antenna feed wire?? CMCon98 Car Audio and Multimedia 1 02-28-2000 04:07 PM



All times are GMT -4. The time now is 03:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page