Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-18-2003, 02:06 PM
Registered User
 
Join Date: Feb 2002
Location: Seattle
Posts: 596
Noisy Antenna, '86 300E

Hello,

I have a noisy power antenna on an '86 300E. It is intermittent, but always happens when I try to extend the antenna to maximum -- the motor no longer shuts off automatically -- it makes a ratchety sound until I reset the swith to the 'medium' middle setting.

Question: Is this most likely the nylon gear strip inside the mast or the belt drive internal to the motor?

Thanks!
__________________
David
1986 300E Anthracite + ECodes + MB Mileage Award
Reply With Quote
  #2  
Old 03-18-2003, 03:54 PM
csnow's Avatar
Registered User
 
Join Date: May 2002
Location: Mass
Posts: 1,127
Try helping it along as it attempts to extend. If that works, perhaps it just needs a good cleaning and lube.

May be worth taking it apart to get the gears and 'mast cord' lubed. Could pay off down the road.

The drive belt and mast are actually available and replaceable parts.

Mine had similar symptoms, and I found that a plastic part that engaged the spring had snapped. I epoxied it back together.
__________________
1986 300E 5-Speed 240k mi.
Reply With Quote
  #3  
Old 06-03-2003, 06:55 PM
Registered User
 
Join Date: Feb 2002
Location: Seattle
Posts: 596
Replaced Mast. Tore apart motor and cleaned. All is perfect now.
__________________
David
1986 300E Anthracite + ECodes + MB Mileage Award
Reply With Quote
  #4  
Old 06-04-2003, 11:24 AM
Joseph_H's Avatar
Registered User
 
Join Date: Nov 2002
Location: Texas
Posts: 231
David, Was it easy?

... to replace the mast and clean/lube the motor? any special lubricant to use? My E420 antenna make a noise when being extended or retracted and maybe i need to do the same thing to it. Thanks.
__________________
Joe95E420
Reply With Quote
  #5  
Old 06-04-2003, 11:27 AM
Zeus's Avatar
Moderating, Eh?
 
Join Date: Feb 2000
Location: Canada
Posts: 1,774
Hey Joe -

I recently replaced the mast on my 300E. Piece of cake - 5 minute job. The instructions came with the new Hirschmann mast. I also took it all apart and tried cleaning the old mast and lubing the motor works inside, but the old mast was so dirty and kinked that I just bought a new one. The motor isn't cheap, a new mast is. I would just replace the mast if I were you. The motor generally doesn't need to be cleaned/lubed but you could always take it apart and do so. Mine was pretty clean and well lubed inside.
__________________
Chris
2007 E550 4Matic - 61,000 Km - Iridium Silver, black leather, Sport package, Premium 2 package
2007 GL450 4Matic - 62,000 Km - Obsidian Black Metallic, black leather, all options
1998 E430 - sold
1989 300E - 333,000 Km - sold
1977 280E - sold
1971 250 - retired


"And a frign hat. They gave me a hat at the annual benefits meeting. I said. how does this benefit me. I dont have anything from the company.. So they gave me a hat." - TheDon
Reply With Quote
  #6  
Old 06-04-2003, 11:35 AM
Joseph_H's Avatar
Registered User
 
Join Date: Nov 2002
Location: Texas
Posts: 231
Thanks Chris

Where did you buy the mast from? dealer? Do you know how much they sell for? I will try to replace the mast myself as you indicate it being a simple task. Do you recommend I buy a Hirschmann brand? Thanks again.
__________________
Joe95E420
Reply With Quote
  #7  
Old 06-04-2003, 11:38 AM
csnow's Avatar
Registered User
 
Join Date: May 2002
Location: Mass
Posts: 1,127
I recall the mast replacement was pretty easy.
Most of the time in my case was invested in cleaning and roughing things up, because I needed to epoxy a broken plastic part (the part that engages the shock absorbing spring-not available separately).

The old grease was all hardened up and done. Fortunately, the plastic gears were still in good shape. I replaced the drive belt (cheap) for good measure, though it appeared to be fine.

I would suggest a thorough cleaning, which may require some extra disassembly.

I lubed everything with silicone grease (NOT silicone spray which is very different), available in tubes at most auto parts stores. I feel this is the best stuff for plastic parts.

Best of luck.
__________________
1986 300E 5-Speed 240k mi.
Reply With Quote
  #8  
Old 06-04-2003, 11:39 AM
csnow's Avatar
Registered User
 
Join Date: May 2002
Location: Mass
Posts: 1,127
Our sponsor carries the mast.
__________________
1986 300E 5-Speed 240k mi.
Reply With Quote
  #9  
Old 06-04-2003, 12:02 PM
Zeus's Avatar
Moderating, Eh?
 
Join Date: Feb 2000
Location: Canada
Posts: 1,774
Fastlane here does indeed carry the mast and their service is excellent! I would buy it from them. It is $30 for the Hirschmann, which is the original part. Not sure if there even is an alternative. I'm in Canada, so I got the mast from my mechanic who stocks the part regularly. I paid $40 CDN. Good luck!
__________________
Chris
2007 E550 4Matic - 61,000 Km - Iridium Silver, black leather, Sport package, Premium 2 package
2007 GL450 4Matic - 62,000 Km - Obsidian Black Metallic, black leather, all options
1998 E430 - sold
1989 300E - 333,000 Km - sold
1977 280E - sold
1971 250 - retired


"And a frign hat. They gave me a hat at the annual benefits meeting. I said. how does this benefit me. I dont have anything from the company.. So they gave me a hat." - TheDon
Reply With Quote
  #10  
Old 06-04-2003, 12:05 PM
BlackE55
Guest
 
Posts: n/a
Mine was caput about a 18 months ago, so replaced it with OEM parts. A few weeks ago it became loud and slow, esp. when retracting. I simply sprayed a cloth with WD-40 and wiped down the mast. Now it works like new.
Reply With Quote
  #11  
Old 06-04-2003, 12:05 PM
mike690003's Avatar
Registered User
 
Join Date: Apr 2003
Location: Miami,FL
Posts: 807
I hated the long ugly antenna on my 300e, the reception sucked, so I shaved it off. I have an internal antenna in my cdplayer that outperforms my old antenna (on am and fm).My car also looks much cleaner now.
Reply With Quote
  #12  
Old 06-04-2003, 12:13 PM
Zeus's Avatar
Moderating, Eh?
 
Join Date: Feb 2000
Location: Canada
Posts: 1,774
Yeah, I wipe my antenna down periodically every few weeks or so. I think you have to if you want it to continue to work smoothly. It fits together so tightly, there is no room for any guck on the mast. I just use a little penetrating oil on a clean rag and wipe it down. It's been working perfectly ever since...
__________________
Chris
2007 E550 4Matic - 61,000 Km - Iridium Silver, black leather, Sport package, Premium 2 package
2007 GL450 4Matic - 62,000 Km - Obsidian Black Metallic, black leather, all options
1998 E430 - sold
1989 300E - 333,000 Km - sold
1977 280E - sold
1971 250 - retired


"And a frign hat. They gave me a hat at the annual benefits meeting. I said. how does this benefit me. I dont have anything from the company.. So they gave me a hat." - TheDon
Reply With Quote
  #13  
Old 06-04-2003, 12:14 PM
BlackE55
Guest
 
Posts: n/a
Quote:
Originally posted by mike690003
I hated the long ugly antenna on my 300e, the reception sucked, so I shaved it off. I have an internal antenna in my cdplayer that outperforms my old antenna (on am and fm).My car also looks much cleaner now.

HA! I guess size doesn't matter!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page