Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-26-2003, 08:08 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
'95 Wagon Rear Door Speakers Do Not Work!

The '95 Wagon Rear Door Speakers Do Not Work, both of them.

Does any body know- Does this radio have a separate AMP? If so where is it hiding?

Someone posted about a crimped/cut-wiring loom from the front to the back, under the driver's seat-

I want to fix this but I am at a loss as to where to start tracing the wiring and test for broken wires.

Any help would be greatly appreciated.

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #2  
Old 04-26-2003, 09:13 PM
Registered User
 
Join Date: Feb 2000
Location: Rancho PV, CA, USA
Posts: 328
May we assume the obvious that you have checked the fader control? Ed
Reply With Quote
  #3  
Old 04-26-2003, 11:03 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Ed, Ed, Ed .... I wish that were all it was ..... thanks for the bump!

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #4  
Old 04-27-2003, 01:15 PM
Registered User
 
Join Date: Feb 2000
Location: Rancho PV, CA, USA
Posts: 328
I see my response does sound a bit condescending, I did not mean it to be, my apologies. As you know, there have been many queries where the obvious has been overlooked. I also have an E wagon, but would have no further idea as to the source of your problem. Ed
Reply With Quote
  #5  
Old 04-27-2003, 07:19 PM
La Jolla Audio
 
Join Date: Dec 2001
Location: San Diego California
Posts: 996
Did you start by pulling the speakers out and checking to see if there is sound present by hooking up another speaker you know works? Try pulling one of your front dash speakers out.

Scott@lajollaaudio
__________________
The Mercedes Specialists Since 1986
Reply With Quote
  #6  
Old 04-27-2003, 09:55 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Yes, I substituted speakers at each of the doors and no sound.
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #7  
Old 04-28-2003, 01:51 AM
La Jolla Audio
 
Join Date: Dec 2001
Location: San Diego California
Posts: 996
do you have a fader control in the console?
__________________
The Mercedes Specialists Since 1986
Reply With Quote
  #8  
Old 04-29-2003, 12:36 AM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
No console fader switch, it has the later "round knob" radio. Using the radio head fader, biased full to the rear, no sound comes out of the rear speakers.

Can anybody help here .... how do I trace the wiring from each of the rear door speakers (arm rests)?

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #9  
Old 04-29-2003, 02:29 AM
La Jolla Audio
 
Join Date: Dec 2001
Location: San Diego California
Posts: 996
Do you have a cd changer? if you do try unplugging it and the adapter and see if you have rear speakers. There is a ground loop that will happen and it tells the radio to just be a 2 ch out for the 94 cars that still had a console fader control.

Scott
__________________
The Mercedes Specialists Since 1986
Reply With Quote
  #10  
Old 04-29-2003, 12:58 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Scott

Since my car does not have the console fader switch, are you suggesting that I pull the radio and disconnect the CD changer connection anyway?

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #11  
Old 04-30-2003, 12:56 AM
La Jolla Audio
 
Join Date: Dec 2001
Location: San Diego California
Posts: 996
Yes as there is a circuit that grounds to allow only a 2 ch output of the radio when there is a fader switch and this is on the cd changer cable. If a wrie is shorted on the cable the cd changer would still work but it could keep the radio from having a 4 ch output. Whille the radio is out you can also hook up a test speaker to the rear outputs of the radio to test for sound there.

Scott
__________________
The Mercedes Specialists Since 1986
Reply With Quote
  #12  
Old 04-30-2003, 01:02 AM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Scott

Great suggestions, will do.

Thanks,

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #13  
Old 05-01-2003, 11:33 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
OK, I hooked up and tested the rear channels .... got sound out of both directly off the radio.

Now I suspect the wiring .... any suggestions as to where I should trace ....

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #14  
Old 05-11-2003, 06:29 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Update:

Both (remarkable) rear speakers were bad. Replaced them. Both rear channels of the radio head were bad (weird).

Now I have to figure out whether the radio is worth repairing....

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #15  
Old 05-11-2003, 10:55 PM
wjm's Avatar
wjm wjm is offline
Statman
 
Join Date: Dec 2000
Location: Suburban Detroit, MI
Posts: 692
Are you saying both rear channels and both rear speakers were blown??? Wow!

Does your radio look like this?


If so, keep an eye out on ebay. You'll find these out there quite often AND you can usually get it for a decent price. Make sure though that you get the CODE for the radio.

I found one at least one out there:
http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&category=6774&item=2414874979

You can also check here for radio (one of my favorite parts site:

http://car-part.com

Lastly, to repair or exchange the radio (as you probably already know), go here:

http://www.beckerautosound.com/

Willy

Last edited by wjm; 05-11-2003 at 11:25 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page