Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-23-2003, 02:29 PM
Registered User
 
Join Date: May 2003
Location: Po'town, NY
Posts: 106
Europa II to 754 in '78 280 E

My 25 yr. old Europa doesn't go off when switched off and has ignition noise coming through the speakers all the time. I've checked the connections and they are good. I plan to pull the Europa and have Beck N/A. do their thing with it. In the mean time, I have a nice Becker 753(Euro model) off of ebay I would like to put in when the Europa is off campus at the spa.

Am I nuts? I know I need to pull a constanly hot line from the battery or hot relay, but can I take it off the clock line in the instrument pod? What other hurdles should I expect? I know my AM reception will suffer due to differences in Euro vs US frequencies.

I'm not a complete novice, but have ended up deeper into projects than I knew how to get out of with minimal damage.
Thanks in advance for your help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page