Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-03-2003, 11:20 AM
Zeus's Avatar
Moderating, Eh?
 
Join Date: Feb 2000
Location: Canada
Posts: 1,774
Question Alpine Ai-Net CD changer help...Scott?

I was given a used Alpine Ai-Net CD changer from a friend. It's a CHA-S624 model. I have the exact same model installed in my car as well. This used one would be for my brother's car. When I connected it, it powered up but the cartridge was stuck inside and it would not eject. I fiddled with it a bit and it popped out. It now loads and ejects the cartridge properly.

However, it does not read CDs. When I select a CD using my head unit, it loads the CD and attempts to play it, but no sound comes out? It then reads as if that slot was empty and it moves on to the next position. I loaded the cartridge with 6 good CDs and when I select one to play, it loads and runs through all of the CDs but doesn't play any of them? It marks the slot as empty even though there is a perfectly good CD inside. Weird...

Is this an easy fix or is the unit toast? any ideas?
__________________
Chris
2007 E550 4Matic - 61,000 Km - Iridium Silver, black leather, Sport package, Premium 2 package
2007 GL450 4Matic - 62,000 Km - Obsidian Black Metallic, black leather, all options
1998 E430 - sold
1989 300E - 333,000 Km - sold
1977 280E - sold
1971 250 - retired


"And a frign hat. They gave me a hat at the annual benefits meeting. I said. how does this benefit me. I dont have anything from the company.. So they gave me a hat." - TheDon
Reply With Quote
  #2  
Old 07-05-2003, 07:13 PM
La Jolla Audio
 
Join Date: Dec 2001
Location: San Diego California
Posts: 996
You might e mail Cleeve at www.lajollaaudiorepair .com and see what he says about your cdc problem... I don't remember seeing that problem before.

Scott
__________________
The Mercedes Specialists Since 1986
Reply With Quote
  #3  
Old 07-06-2003, 01:48 AM
Registered User
 
Join Date: May 2002
Location: ON., CANADA
Posts: 19
Is your Alpine CHA-S624 changer connected to your original 300E factory radio via an interface or an aftermarket head unit?

I inherited the same Alpine changer but am not sure if I can make it work with my '98 C230's radio (Becker 1692 non Bose) via an interface.

Your help is appreciated!
__________________
1998 C230
Reply With Quote
  #4  
Old 07-06-2003, 02:31 AM
La Jolla Audio
 
Join Date: Dec 2001
Location: San Diego California
Posts: 996
You will need an mbzil adapter from peripheral and an ai to m buss adapter and it will work with your 98 radio. By the way the radios are the same whether or not you have the bose system from 94 on...


Scott
__________________
The Mercedes Specialists Since 1986
Reply With Quote
  #5  
Old 07-08-2003, 02:25 PM
Zeus's Avatar
Moderating, Eh?
 
Join Date: Feb 2000
Location: Canada
Posts: 1,774
Thanks for the reply Scott, much appreciated. I tried that link though and it doesn't work??? Is cleeve's e-mail simply cleeve@lajollaaudiorepair.com? Thx...
__________________
Chris
2007 E550 4Matic - 61,000 Km - Iridium Silver, black leather, Sport package, Premium 2 package
2007 GL450 4Matic - 62,000 Km - Obsidian Black Metallic, black leather, all options
1998 E430 - sold
1989 300E - 333,000 Km - sold
1977 280E - sold
1971 250 - retired


"And a frign hat. They gave me a hat at the annual benefits meeting. I said. how does this benefit me. I dont have anything from the company.. So they gave me a hat." - TheDon
Reply With Quote
  #6  
Old 07-09-2003, 06:03 AM
La Jolla Audio
 
Join Date: Dec 2001
Location: San Diego California
Posts: 996
The e mail address is ljrepair@pac bell.net
__________________
The Mercedes Specialists Since 1986
Reply With Quote
  #7  
Old 07-09-2003, 09:50 AM
Zeus's Avatar
Moderating, Eh?
 
Join Date: Feb 2000
Location: Canada
Posts: 1,774
Thanks Scott!
__________________
Chris
2007 E550 4Matic - 61,000 Km - Iridium Silver, black leather, Sport package, Premium 2 package
2007 GL450 4Matic - 62,000 Km - Obsidian Black Metallic, black leather, all options
1998 E430 - sold
1989 300E - 333,000 Km - sold
1977 280E - sold
1971 250 - retired


"And a frign hat. They gave me a hat at the annual benefits meeting. I said. how does this benefit me. I dont have anything from the company.. So they gave me a hat." - TheDon
Reply With Quote
  #8  
Old 07-09-2003, 01:06 PM
Registered User
 
Join Date: May 2002
Location: ON., CANADA
Posts: 19
Scott, is it the Alpine KCA-130B the ai to mbus adapter you mentioned?

Also, do you carry the Peripheral MBZIL adapter I need for the CHA-S624? I couldn't find anyone who carried Peripheral here in Toronto. Thanks.
__________________
1998 C230
Reply With Quote
  #9  
Old 07-09-2003, 03:58 PM
Zeus's Avatar
Moderating, Eh?
 
Join Date: Feb 2000
Location: Canada
Posts: 1,774
Benz288 - sorry I didn't reply earlier - my CD changer is connected to an aftermarket Alpine Ai-net compatible head unit.
__________________
Chris
2007 E550 4Matic - 61,000 Km - Iridium Silver, black leather, Sport package, Premium 2 package
2007 GL450 4Matic - 62,000 Km - Obsidian Black Metallic, black leather, all options
1998 E430 - sold
1989 300E - 333,000 Km - sold
1977 280E - sold
1971 250 - retired


"And a frign hat. They gave me a hat at the annual benefits meeting. I said. how does this benefit me. I dont have anything from the company.. So they gave me a hat." - TheDon
Reply With Quote
  #10  
Old 07-10-2003, 01:50 AM
La Jolla Audio
 
Join Date: Dec 2001
Location: San Diego California
Posts: 996
Yes the 130 b is the ai to m bus and I always carry all mbz changers and adapters.

Scott
__________________
The Mercedes Specialists Since 1986
Reply With Quote
  #11  
Old 07-11-2003, 02:21 AM
Registered User
 
Join Date: May 2002
Location: ON., CANADA
Posts: 19
Thanks Zeus and Scott!!!
__________________
1998 C230
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page