Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-12-2003, 12:11 PM
Registered User
 
Join Date: Feb 2002
Location: Philippines
Posts: 111
95 C36 no output from rear deck speakers

I have the original much-maligned BOSE premium system with the OEM Becker radio. I recently noticed that the 4 speakers on the rear deck lid above the trunk are not producing any sound at all. The little bass that the system used to produced had dwindled even further.

The tweeters on the dash, the 2 front door subs and the rear door speakers are all ok, although the rear door speakers seem weak compared to the fronts. I have adjusted the fader and balance controls to no avail.

I took a ride in a friend's late-model Lexus and the superiority of his stock sound system to mine was embarrassing.

Any ideas on how I can address this? Are the rear deck-lid speakers really that weak? I put my ear right againts the speakers and still can't hear anythng from them. I don't want to replace my head unit for cosmetic reasons so perhaps I can replace the power amp with a better one?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page