Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-18-2004, 04:09 PM
Registered User
 
Join Date: Sep 2003
Posts: 14
w140 bose amplifier (S class) info.

thought i would let everyone know that i finally, after 6 months i cleared up my speaker "popping problem." i know that this amp has been known to have problems so i suspected that it was the culprit. to make a long story short, i replaced both the amplifier and the head unit to no avail - turns out it was the "amplifier tuner" that was defective. this unit sits right over the left rear wheel in the trunk.

* now i sit with two amps...anyone who needs a replacedment w140 bose amplifer, i have one for sale that works perfectly fine. i was going to put it on Ebay but wanted to give everyone a chance here first. first $300 takes it. thanks.

Ben (onlygreen22@msn.com)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page