Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-19-2004, 06:03 PM
Senior Member
 
Join Date: Feb 2001
Location: Canton,Texas
Posts: 987
Defrost actuator location?

Where under the dash is the actuator for the defrost flap? I've got constant defrost (HEAT!!), as if the flap is stuck open, since it was used a couple weeks ago. Everything else seems to work ok..... the center vents don't work sometimes but they were like that before (that actuator seems to be a little weak on opening the flap). The defrost is the only thing I can't see how the flaps are opened and closed (at least that I know of).

I'm looking at everything from pass. side with glovebox out and kick-panel off btw. If I pull drivers kick-panel will I see the the suspect?

__________________
1985 300D Turbo ~225k
2000 F350 (Powerstroke) 4X4, SWB, CC, SRW, 6spd ~148k
1999 International 4900, DT466e (250hp/660 ft/lbs), Allison MD3060 ~73k
Reply With Quote
  #2  
Old 10-19-2004, 06:05 PM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 12,781
The defroast actuator is to the right of your right foot in the drivers footwell. Pull the panel above your knees and you should be able to get to it. Be aware that full defroast is failure mode for the pushbutton unit.
__________________
Jim
Reply With Quote
  #3  
Old 10-19-2004, 07:11 PM
Senior Member
 
Join Date: Feb 2001
Location: Canton,Texas
Posts: 987
No, no, you aren't supposed to tell me that part yet! Actually, I already knew that but I'm hoping for the best. The other vents blow when they are supposed to and don't when defrost is actually on so I'm hoping something is just stuck.
__________________
1985 300D Turbo ~225k
2000 F350 (Powerstroke) 4X4, SWB, CC, SRW, 6spd ~148k
1999 International 4900, DT466e (250hp/660 ft/lbs), Allison MD3060 ~73k
Reply With Quote
  #4  
Old 10-19-2004, 07:42 PM
Registered User
 
Join Date: May 2002
Location: Central Oregon
Posts: 1,004
If the others are leaking....

Well if the other pods leak then the loss of vacuum causes the default of defrost.
I just took two pods offline with golf tees on mommies SD yesterday for this same reason.
I hate this part of the system. Trying to get to the pods is a real adventure.
__________________
'99 S420 - Mommies
'72 280SE 4.5 - looking to breathe life into it
'84 300SD Grey - Sold
'85 300SD Silver - Sold
'78 Ski Nautique
Reply With Quote
  #5  
Old 10-19-2004, 08:45 PM
Senior Member
 
Join Date: Feb 2001
Location: Canton,Texas
Posts: 987
Hmmm.... maybe I got lucky and another pod went bad (or even better the defrost one). I should at least be able to get it off of defrost now that I know where it is.
__________________
1985 300D Turbo ~225k
2000 F350 (Powerstroke) 4X4, SWB, CC, SRW, 6spd ~148k
1999 International 4900, DT466e (250hp/660 ft/lbs), Allison MD3060 ~73k
Reply With Quote
  #6  
Old 10-20-2004, 01:25 PM
Registered User
 
Join Date: May 2002
Location: Central Oregon
Posts: 1,004
Swithcover valves on a 85 300

I don't know the location of the switchover valves on your car but ont he SD they are located on the right hand side (passenger) of the dash such that by removing the carpeting on that side you can access them without tearing out the controller or the console.
I used my MityVac to test all the pods and valves from here and it made it quite easy. They are all color coded too but some of the ccombinations that make heat/cold air and out of which vents still takes a rocket scientist (or someone with more patience than me) to figure out.
I just stuck golf tees in the source feed to each switchover valve where the pods were bad. Quick fix and virtually all the vents work still because mine were the fresh air vents which I doubt I really need this winter.
Next year I pull it all apart and replace diaphragms.
__________________
'99 S420 - Mommies
'72 280SE 4.5 - looking to breathe life into it
'84 300SD Grey - Sold
'85 300SD Silver - Sold
'78 Ski Nautique
Reply With Quote
  #7  
Old 10-20-2004, 06:03 PM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 12,781
The defroast pod (on the 300D) it not really that hard to get to. It is the center vent pods that are a pia.

__________________
Jim
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page