Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-22-2004, 10:18 AM
SEBREN
Guest
 
Posts: n/a
Cool Bad Fuel?

I Just Bought An 84 300d A Week Ago. Yesterday I Filled It Up For The First Time Since Buying It, And Now The Engine Sounds Really Rough And Loud. It Still Runs Good, It Just Sounds Like Crap. I'm Afraid I Either Got Bad Fuel Or Accidentally Used Off-highway Diesel. What Can I Do?

Reply With Quote
  #2  
Old 10-22-2004, 10:21 AM
tomm9298's Avatar
Diesel and WVO ..
 
Join Date: Sep 2004
Location: South Carolina NO RUST
Posts: 502
Thumbs up Bad fuel

Could be bad fuel, or maybe you washed some algea/crud loose and it has partialy clogged the tank screen and/or fuel filter. Easy place to start, except if it's the tank screen, you must drain the tank first.
__________________
1984 300D Turbo Sedan (Hilda) 272,115 miles.....
Anthracite Gray/Palamino Leather, I am 3rd owner

2001 Dodge Stratus (Silver) (wifes) 55814 miles...

1982 280TE Wagon Astral Silver Metallic/
Anthracite Velour
260,512 miles (Eva)

1969 230 Sedan Olive Green/Black MBTex
4 Speed Manual
84,213 miles ????
Haus Frau


2004 Boreem Ninja Pocket Bike
Highly Modified 49cc (Ling Ling)

Einigkeit und Recht und Freiheit
Reply With Quote
  #3  
Old 10-22-2004, 11:49 AM
R Leo's Avatar
Stella!
 
Join Date: Mar 2003
Location: En te l'eau Rant
Posts: 5,393
Red fuel unlikely...

Off highway diesel is the same as taxed fuel with the exception of the red dye. It will not make any difference in how your engine runs.

But, if you are wondering whether or not you are running 'red fuel', look at the clear prefilter next to the lift pump on the IP and you'll be able to see the fuel color...so will the Feds.
__________________
Never a dull moment at Berry Hill Farm.
Reply With Quote
  #4  
Old 10-22-2004, 02:16 PM
SEBREN
Guest
 
Posts: n/a
could be car

i just used some STP fuel treatment, and that didn't seem to help any. when i get the car up to speed it sounds fine, but at low speeds when i ease my foot off the gas, the engine makes a scratchy, abrasive sound. any ideas? should i take it in?
Reply With Quote
  #5  
Old 10-22-2004, 02:21 PM
Member since 2000
 
Join Date: Jul 2003
Location: Flemington, NJ
Posts: 1,143
Sounds simple but did you check your oil level?
Reply With Quote
  #6  
Old 10-22-2004, 02:44 PM
tomm9298's Avatar
Diesel and WVO ..
 
Join Date: Sep 2004
Location: South Carolina NO RUST
Posts: 502
Thumbs up Start easy

I live by the KISS principal.
K = keep
I = it
S =super
S = simple

Start with the easiest to check then the cheapest to repair. Many problems are caused by cheap parts that are easy to replace.

__________________
1984 300D Turbo Sedan (Hilda) 272,115 miles.....
Anthracite Gray/Palamino Leather, I am 3rd owner

2001 Dodge Stratus (Silver) (wifes) 55814 miles...

1982 280TE Wagon Astral Silver Metallic/
Anthracite Velour
260,512 miles (Eva)

1969 230 Sedan Olive Green/Black MBTex
4 Speed Manual
84,213 miles ????
Haus Frau


2004 Boreem Ninja Pocket Bike
Highly Modified 49cc (Ling Ling)

Einigkeit und Recht und Freiheit
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page