Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-11-2005, 10:22 PM
Registered User
 
Join Date: Feb 2001
Location: Midwest, USA
Posts: 171
Possessed Glow Plug Light-New Relay!

I recently had to get a new glow plug relay for my '79 300SD. I now have the strangest problem. I know what it means when the glow plug light flashes for thirty seconds after a start, and the other fault indicators that the light gives, but...

Why on earth is my light flashing randomly for the entire time I'm driving my car???? From once every half an hour, to once every five seconds, to once or twice in a row, you get the picture. I almost thought that it happened only while running the heater, but soon proved myself wrong.

I wonder if I have a defective relay? Any ideas or experiences with this?

It's driving me crazy. Thanks!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page