PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Diesel Discussion (http://www.peachparts.com/shopforum/diesel-discussion/)
-   -   My Rad. Has No Drain !! (http://www.peachparts.com/shopforum/diesel-discussion/114669-my-rad-has-no-drain.html)

Dervman 02-03-2005 01:04 PM

My Rad. Has No Drain !!
 
Went to drain the coolant in my ,87 SDL last night and found that there was no drain on the lower Radiator housing. I mean none, not even a bolt or bushing. :mad:
The rad. is a replacement OE Behr that was installed by the PO in 2000.
I had to remove the lower Rad. Hose to drain the coolant - very messy :(
The manual shows a drain plug but it definitely wasn't there on mine.
Has anybody else come across this :confused:

Brian Carlton 02-03-2005 02:01 PM

I've got what appears to be a replacement Behr in the SDL (installed by PO) and it does have the drain.

Are you sure you are looking for the right thing? It's a plastic threaded piece that is recessed in a cavity. You have to get underneath the vehicle to see it. I seals with an o-ring (that I now believe has to be replaced on mine. :mad: )

Habanero 02-03-2005 02:19 PM

The first time I drained mine it took a little looking to find it. It seemed like the sheet metal under the radiator had been bunged up a little so the access hole for the drain wasn't exactly centered on the drain anymore. Maybe that is the case with yours??

jbaj007 02-03-2005 02:27 PM

It's usually very blue in color.


All times are GMT -4. The time now is 02:33 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website