Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-03-2005, 08:12 PM
Registered User
 
Join Date: Feb 2005
Posts: 3
MBZ Diesel injection pump problem

I have a '93 300D 2.5 turbo and my mechanic told me that he believes the injection pump is going out. He said that hears a noise that may be either the lower or upper bearings in the injection pump and that there is a also a loss of power at higher rpm's. He also said that if it is the upper bearing it would be okay to leave alone but if it is the lower bearing it could be real trouble (due to engine timing issues?). It seems to me that the car is running nice. I don't "race" the engine so I haven't noticed any power losses. This is a really expensive job, so I wanted some advice. The last thing I want to do is neglect a part that could lead to major engine repair later. Does anyone have any suggestions for me?

Thanks,

Mike

Reply With Quote
  #2  
Old 02-03-2005, 09:55 PM
Senior Member
 
Join Date: Feb 2001
Location: Canton,Texas
Posts: 987
I would get another opinion, sounds to me like a fuel starvation problem (like a clogged filter) if you actually do have a problem. I've never heard anything like that about an injection pump, especially not on a MB. Unless you're noticing a problem I actually wouldn't mess with it.

On edit, how many miles does it have on it? That will give us an idea if it actually could be worn out.
__________________
1985 300D Turbo ~225k
2000 F350 (Powerstroke) 4X4, SWB, CC, SRW, 6spd ~148k
1999 International 4900, DT466e (250hp/660 ft/lbs), Allison MD3060 ~73k
Reply With Quote
  #3  
Old 02-03-2005, 10:10 PM
Luke's Avatar
-.- .-.. .- - - .-
 
Join Date: Aug 1999
Location: Saint Helena, CA
Posts: 166
I agree. Get a second opinion. In my reading MB diesel injector pump failure is rare. Look for the simpler solutions first.
__________________
'78 300D 310K Maple Yellow / Bamboo
'87 300D 81K Barolo Red / Safron (RIP @ 113K)
2003 E320 34K Pewter/Charcoal
-------------------------------------
Reply With Quote
  #4  
Old 02-03-2005, 11:15 PM
Geezer
 
Join Date: Aug 2000
Location: Holland, MI
Posts: 1,316
Quote:
Originally Posted by mgellison
I have a '93 300D 2.5 turbo and my mechanic told me that he believes the injection pump is going out... This is a really expensive job, so I wanted some advice. The last thing I want to do is neglect a part that could lead to major engine repair later. Does anyone have any suggestions for me?

Thanks,

Mike
How many miles are on it? M-B IPs are lubricated by engine oil, and last about forever.

Clogged fuel filter(s) will cause a high-rpm power loss.

Some mechanics will say anything to get work, so do get a second opinion.

Best Regards,
Jim
Reply With Quote
  #5  
Old 02-04-2005, 01:33 AM
compress ignite's Avatar
Drone aspiring to Serfdom
 
Join Date: Feb 2004
Location: 32(degrees) North by 81(degrees) West
Posts: 5,554
inline bosch pressure lubed I.P.(s)

mgellison,

Unless the I.P. has been run without oil pressure (engine oil pressurizes I.P.)
OR your car has 1,000,000++ miles on it 'hardly likley YOUR I.P. is at fault.

It is not completely "Bullet Proof", but due to design and machining
tolerances the I.P. may be the most reliable part of the engine system.
Reply With Quote
  #6  
Old 02-04-2005, 02:01 AM
Registered User
 
Join Date: Feb 2005
Posts: 3
It only has 121k. Here is some more background: I took it in becuase the belt was making a lot of noise, and also it would occasionally make a pretty noticeble "clatter." The clatter was not constant, but rather intermittent. Last year I replaced the timing chain tensioner, so I thought that this clatter might be the timing chain itself or one of the timing chain guides as it seemed like the noise was up in the front of the engine.

First the belt and belt tensioner were replaced. That quited it down enough to find that the #1 and #2 lifters were not functioning. I had them (and the others) all replaced. I thought I was getting off easy, but when I went to pick it up, I was told the news about the injection pump. I just don't know enough about the injection pump to understand the implications of it going out.

It is so much quiter and seems to be running great now (to me anyway). I've already spent about $1k and my gut tells me to find out more before spending another $2k. I really love this car and my only real concern is doing more damage by neglecting a potential problem with the injection pump. I don't want to end up spending $7K on a new engine!

If the injection pump is bad or goes out could it lead to a catastrophic engine failure?

It definitely sounds like I should change the filter first. Thanks for the advice.

Mike
Reply With Quote
  #7  
Old 02-04-2005, 10:29 AM
Senior Member
 
Join Date: Feb 2001
Location: Canton,Texas
Posts: 987
If the IP really is bad the car will stop running when it fails...... it shouldn't do any other damage if it fails. In that case you would just need to get a new IP or the old one rebuilt and have it installed. AT 121K the pump should be fine, not very likely to be worn out.

I don't know about this particular car but the lift pump could also be weak and not supplying enough fuel at high rpms, I would still think a clogged filter though.
__________________
1985 300D Turbo ~225k
2000 F350 (Powerstroke) 4X4, SWB, CC, SRW, 6spd ~148k
1999 International 4900, DT466e (250hp/660 ft/lbs), Allison MD3060 ~73k
Reply With Quote
  #8  
Old 02-04-2005, 08:22 PM
Registered User
 
Join Date: Jul 2002
Location: S. Texas
Posts: 1,237
Look in the phone book under Diesel injection shops. Let them listen to it. They have listened to and repaired more Diesel pumps than your MB dealer has had inflated invoices.

They can take off the pump, listen to it, calibrate and repair it if needed, and reinstall it probably for considerably less that the MB dealer.
Reply With Quote
  #9  
Old 02-04-2005, 09:54 PM
Registered User
 
Join Date: Sep 2001
Location: central Texas
Posts: 17,277
Didn't someone say that SOME MB injection pumps need to be manually oiled like old SU Carbs ?
This is a good time to warn about shooting any water on your Injection pump when it is warm... it is very tight fitting and that can ruin it.
Reply With Quote
  #10  
Old 02-10-2005, 01:13 AM
Registered User
 
Join Date: Feb 2005
Posts: 3
Thanks for everyone's input. I will definitely change the fuel filter and get another opinion before I do anything to the injection pump. I think I was being pressured into a repair with the threat of neglect causing greater damage the engine (kind of a "pay me now or pay me more later" type-deal).

I wish I had found this site a long time ago. It's just great and a lot of fun too!

-Mike

previously owned deisels:

1978 240D 4-speed (classy, but dangerously slow)
1984 300SD (classic looks and a great freeway cruiser)
1993 300D 2.5 (current car, a little less classy but the most fun yet)
wish list: S55 (someday)
Reply With Quote
  #11  
Old 02-10-2005, 11:44 AM
Senior Member
 
Join Date: Feb 2001
Location: Canton,Texas
Posts: 987
Ok, this is kind of off topic but since Leathermang brought it up...... has anyone actually ever had a pump hurt by washing it when it's hot? The pump on my tractor gets water splashed on it all the time and still works fine, granted it probably doesn't get as hot as one on a car but it does get warm and it's certainly not unusual for it to be splashed with water when I'm feeding cows in the winter.

__________________
1985 300D Turbo ~225k
2000 F350 (Powerstroke) 4X4, SWB, CC, SRW, 6spd ~148k
1999 International 4900, DT466e (250hp/660 ft/lbs), Allison MD3060 ~73k
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting problem probably due to air in the diesel on a 1994 C250 - any tips John Hamilton Tech Help 4 12-31-2008 09:17 AM
Diesel emissions-the truth rickg Diesel Discussion 60 03-14-2005 06:35 PM
W140 Fuel Pump problem - relay or pump? oestek Tech Help 1 01-27-2005 02:35 PM
FS: 1982 Diesel Fuel Injection Pump OM617 Holson Adi Mercedes-Benz Used Parts For Sale & Wanted 1 12-27-2002 12:23 PM
Injection Pump Shuffle ....solved! headstill Diesel Discussion 1 06-05-2002 11:21 PM



All times are GMT -4. The time now is 10:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page