Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-12-2005, 10:30 PM
Registered User
 
Join Date: Jan 2003
Location: SOUTH JERSEY
Posts: 196
1990 turbo diesel cold start issue

1990 turbo diesel is giving me a cold start issue.. I checked all the glow plugs
with my ammeter and i get a reading on each.. my glow plug light cycles correctly
it does NOT light up after i start the car... switched my glow plug relay from my 1992 turbo with same results as follows..

car runs rough for first 15 to 20 seconds almost like i do have a bad glow plug.. she belches a ton of blue smoke for 10 or so seconds then all of a sudden she runs fine as if all cylinders are running..

at first i thought i had a bad glow plug but i get a readng on each of the 5 plugs..

note.. when the engine is warm she starts fine

also when i do plug in the block heater i do get a few seconds of rough idle and smoke maybe 3-4 seconds then all is fine..

i ran a can of lubro moly diesel purge straight thru the injectors with the glass jar and the by pass line etc.. replaced both spin on and inline filters as well

the car runs perfect after 15 no more than 20 seconds... then smoke stops as if nothing has happened...

its driving me crazy... could it be carbon build up on the glow plugs ? or something more serious..?>?

igition pump seems to be in time car has 220 k and i currently have rotella t 5-50 synthetic in the crank case..

any ideas??
__________________
1994 S-350 6cyl Turbo Diesel 158k

1998 300d 6 cyl Turbo Diesel 143K

1993 2.5 124 Turbo-Diesel 236

1990 2.5 124 Turbo-Diesel 228k

1983 SL-500 EURO W/HEATED SEATS 40K

SOLD 1977 Jaguar XJ6 Coupe Antique Roadster 85K

SOLD 1993 2.6 6 cyl 190 E 150k

SOLD 1992 2.5 124 Turbo-Diesel 204k

RIP 1992 124 300 TD 265K OIL PUMP QUIT @ 85MPH
Reply With Quote
  #2  
Old 03-12-2005, 11:04 PM
Registered User
 
Join Date: Jan 2003
Location: Reno/Sparks, NV
Posts: 3,063
Try glowing your plugs for 30 seconds in one cycle before starting the engine. How did you check your glow plugs? I test mine for resistance through the relay connector when they're cold, and then once more right after glowing them. You should see 0.5 to 1.0 ohm cold, and much more when hot.
__________________
2004 VW Jetta TDI (manual)

Past MB's: '96 E300D, '83 240D, '82 300D, '87 300D, '87 420SEL
Reply With Quote
  #3  
Old 03-12-2005, 11:14 PM
Registered User
 
Join Date: Jan 2003
Location: SOUTH JERSEY
Posts: 196
uh huh

yes i did the same thing when cold by checking the resistance from the

relay connector.. i will check them when they are hot..

i hate to replace all the glow plugs just for the heck of it..

besides #1 is really hard to get to
__________________
1994 S-350 6cyl Turbo Diesel 158k

1998 300d 6 cyl Turbo Diesel 143K

1993 2.5 124 Turbo-Diesel 236

1990 2.5 124 Turbo-Diesel 228k

1983 SL-500 EURO W/HEATED SEATS 40K

SOLD 1977 Jaguar XJ6 Coupe Antique Roadster 85K

SOLD 1993 2.6 6 cyl 190 E 150k

SOLD 1992 2.5 124 Turbo-Diesel 204k

RIP 1992 124 300 TD 265K OIL PUMP QUIT @ 85MPH
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Excellent Diesel Article Ron Johnstone Diesel Discussion 7 02-18-2005 03:18 PM
300E cold start question schumi Tech Help 0 10-13-2003 12:22 PM
cold start lever on w123 diesel sdelasal Diesel Discussion 1 06-22-2003 08:18 PM
420 SEL does not start at all. Checked OVP, Cold Start Valve, replaced Check Valves xsohaib Tech Help 7 12-12-2002 11:25 AM
Help - 1990 2.6 Engine Stumble and Dies on First Start (and I did do a search first) avusblue Tech Help 9 06-26-2001 01:04 PM



All times are GMT -4. The time now is 02:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page