Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-27-2005, 02:16 AM
WANT '71 280SEL's Avatar
I'll Go Upside Your Head!
 
Join Date: Jan 2003
Location: Dallas, TX
Posts: 3,378
'87 300SDL ACC problems (minor?)

I did a search and I believe I answered the first of my questions, but here it goes.

Of the 3 times I've used my A/C this past week, I have only gotten air out of the center vent once. A search made me believe this is the vacuum pod behind the antenna radio. It was my belief that when they fail they always blow air out the vents rather than vice-versa.

Secondly, I am having a problem getting a high speed from my blower motor. When I was using the A/C I turned the wheel to "min" and the fan hardly goes above the middle speed. Then, tonight I tried to use the defroster to get the car heated up since it was cold outside and didn't blow hard until I had been driving for 20 minutes. This happens to me almost all the time. If it is in auto mode and I push the "max" speed mutton, the fan hardly turns up the volume. Sometimes it will blow hard like it should after awhile of running, and most of the time it won't. Do you guys have any idea what this problem could be?

I have to say that my ACC puts out the right temperatures in that it blows cold when calling for A/C and puts out good heat when told to do so, it's just the fan speed that's messed up.

Thanks
David

P.S.
How do I remove the wood piece above the radio so I can replace the pod? I don't see any screws and I know it has two "J" shaped hooks at the top...
__________________
_____________________________________________

2000 Honda Accord V6 137k miles

1972 300SEL 4.5 98k miles

_____________________________________________
Reply With Quote
  #2  
Old 03-28-2005, 12:08 AM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 20,323
If you get cold air from the center vens sometimes and blower control is iffy, I think the more likely culprit is a tired ACC PBU.

To remove the panel that houses the ACC controls and the bank of switches above, remove the 2 screws along the bottom of panel exposed when the radio is out. The screws point upwards. Pull down on the panel as you pull it out. As you remove and replace the panel, mind the fiber optic cables that illuminate the switches.

Sixto
95 S420
87 300SDL
Reply With Quote
  #3  
Old 03-28-2005, 09:50 AM
Registered User
 
Join Date: Jun 2004
Location: West of Ft. Worth. TX
Posts: 4,093
On your Climate Control Pushbutton Unit, usually resoldering the board connections inside will take care of intermittent problems. If you are not handy with a small soldering iron, bribing a friend may help.
__________________
Sam

84 300SD 350K+ miles ( Blue Belle )
Reply With Quote
  #4  
Old 03-28-2005, 10:56 AM
WANT '71 280SEL's Avatar
I'll Go Upside Your Head!
 
Join Date: Jan 2003
Location: Dallas, TX
Posts: 3,378
I have to pull the radio to get the ACC controller out? How does one remove the radio? I read here about removing the face but hoe does one do that?

Thanks
David
__________________
_____________________________________________

2000 Honda Accord V6 137k miles

1972 300SEL 4.5 98k miles

_____________________________________________
Reply With Quote
  #5  
Old 03-28-2005, 06:53 PM
Registered User
 
Join Date: Jun 2004
Location: West of Ft. Worth. TX
Posts: 4,093
Do you have an aftermarket radio? On each side of the radio are there 2 small holes? If so, you can make your own removal tools out of wire coat hanger. Just cut & bend (2) u-shaped pieces about 3-4" long. Insert the ends into the holes about 1/2" and it should release.

If you have the original Becker, I have not dealt with removing that brand and could not tell you.
__________________
Sam

84 300SD 350K+ miles ( Blue Belle )
Reply With Quote
  #6  
Old 03-28-2005, 08:20 PM
WANT '71 280SEL's Avatar
I'll Go Upside Your Head!
 
Join Date: Jan 2003
Location: Dallas, TX
Posts: 3,378
It's still the stock Becker.

Thanks
David
__________________
_____________________________________________

2000 Honda Accord V6 137k miles

1972 300SEL 4.5 98k miles

_____________________________________________
Reply With Quote
  #7  
Old 03-29-2005, 01:57 AM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 20,323
I have not met the Becker in a W126 that I could not remove by reaching into the ashtray cavity and pushing out the stereo unit.

Sixto
95 S420
87 300SDL
Reply With Quote
  #8  
Old 03-29-2005, 03:00 AM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 20,323
Also, the 86-up ACC PBU is more complicated than the 81-85 PBU since it incorporates the function of the separate temp control unit in the 81-85 ACC system. Getting the bottom cover off is tricky enough, then you have to take the thumbwheels off (they're internally attached, not externally attached like in the 81-85) and possibly desolder the blower control rheostat/pot to be able to remove the daughterboard so you can open up the whole thing for resoldering. It's a lot more complicated, trust me.

When I got the SDL PBU apart, I sent it to a buddy who has access to state-of-the-art flowing facilities. Long story short, a $175 rebuilt PBU is what fixed the problems. Resoldering the external light relay did fix a problem I had with the bulb warning light coming on when I hit a bump or took a hard right turn. Next is the cruise amp which won't engage below 50 mph.

Sixto
95 S420
87 300SDL
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1987 300SDL Idle problems peragro Diesel Discussion 10 07-20-2004 09:08 AM
126 ACC fan problems DaimlerChrysler Tech Help 0 04-06-2004 08:11 AM
2002 C230 Kompressor Problems lorhutton Tech Help 1 10-04-2002 02:58 PM
A few minor problems with a '94 S600 Chard Tech Help 6 07-14-2001 11:00 AM
1987 300SDL Alarm Problems AltruistkFallacy Tech Help 0 03-21-2001 06:26 AM



All times are GMT -4. The time now is 06:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page