Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-04-2005, 01:01 PM
Registered User
 
Join Date: Nov 2002
Location: Richardson TX (work) Mason TX (fun)
Posts: 52
Major Transmission Problem

Transmission on my 300SDL recently died. I was cruising along about 60mph started up a grade and the car slowed. Pressure on the accelerator increased RPMs, but the torque wasn't making its way to the rear wheels. I coasted to the side of the road and stopped. I was able to get the car home less than a mile away in low gear, but I had to rev the engine up and the car would barely move. I've read about the effects of a bad B2 piston, but I don't think that is my problem since reverse does not work either. Fluid level looks OK. Any ideas on what the problem might be? It was shifting OK prior to failure.

Thanks

Reply With Quote
  #2  
Old 08-04-2005, 01:14 PM
BusyBenz
Guest
 
Posts: n/a
I cant answer your question, but I'm curious to know how many miles on the tranny, and how often you change tranny fluid?
Reply With Quote
  #3  
Old 08-04-2005, 01:24 PM
Registered User
 
Join Date: Nov 2002
Location: Richardson TX (work) Mason TX (fun)
Posts: 52
The car has right at 150K miles. service records that came with the car showed fluid change at like 98K miles. It is due for a change. In fact, I had not driven the car since May because 1) I was planning on changing the transmission fluid, filter and cooler lines and 2) The AC does not work that well. I was driving the car that particular day because it was the only vehicle I had available while repairing my truck, which was also broken at the time. It was not a good day.

__________________
'87 300SDL
'96 F250 Crewcab PowerStroke
'00 Kubota L2600
'66 Malibu ragtop (SOLD, sob)
'01 BMW M3 ragtop
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Running list of failures during 3 years of ownership Q ML, GL, G-Wagen, R-Class, Unimog, Sprinter 33 01-22-2006 09:13 AM
HELP! 93 500SEL low power problem Mercedes500sel Tech Help 8 08-18-2005 01:54 AM
240D intermittant starting problem pj67coll Diesel Discussion 12 12-13-2003 08:16 AM
Electrical Problem? 87300SDLTurbo Tech Help 0 10-23-2002 03:29 AM
Igniton switch or Relay Problem cmusante Tech Help 1 10-07-2002 07:00 PM



All times are GMT -4. The time now is 04:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page