Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-17-2005, 09:51 PM
McRoth's Avatar
Registered User
 
Join Date: May 2002
Location: Grafton, OH
Posts: 291
New Voltage Regulator Question

I just replaced the voltage regulator on my alternator & now the battery light comes on when the RPM's are below 2500. Do the new brushes need to get "seated" before it charges correctly? Or should it be instant?

Thanks!

Mike
__________________
Michael Roth

1982 300TDT Wagon
1982 240D Euro!, 4spd manual-Parts car now, dead engine
88 Jeep Grand Wagoneer-fixing up for offroading
1989 Ford F150 (rust bucket) For Sale!
1953 Dodge B-4F, 1 1/2 ton Stake Bed (new restoration project)
Reply With Quote
  #2  
Old 08-17-2005, 10:04 PM
t walgamuth's Avatar
dieselarchitect
 
Join Date: Apr 2005
Location: Lafayette Indiana
Posts: 33,607
i would drive it around for an hour and see if it

changes. if not then something is wrong.

tom w
__________________
[SIGPIC] Diesel loving autocrossing grandpa Architect. 08 Dodge 3/4 ton with Cummins & six speed; I have had about 35 benzes. I have a 39 Studebaker Coupe Express pickup in which I have had installed a 617 turbo and a five speed manual. It still needs upholstery redone...I also have a 427 Cobra replica with an aluminum chassis.
Reply With Quote
  #3  
Old 08-17-2005, 10:22 PM
Hit Man X's Avatar
I LOVE BRUNETTES
 
Join Date: Sep 2004
Location: FUNKYTOWN
Posts: 9,057
Thumbs up

Mine was instant.

Belts are tight and the plug is fully seated correct?
__________________
I'm not a doctor, but I'll have a look.

'85 300SD 244k
'87 300SDL 251k
'90 300SEL 325k
'91 560SEL 189k

Eight others from IH, BMW, GM, Ford, and Volvo.

Liberty will not descend to a people; a people must raise themselves to liberty.
[/IMG]
Reply With Quote
  #4  
Old 08-28-2005, 12:35 PM
McRoth's Avatar
Registered User
 
Join Date: May 2002
Location: Grafton, OH
Posts: 291
Well, I replaced the alternator the other day with an almost new one I had on my 240D. I looked at the copper shaft that the brushes turn on & it was WAY worn down. That seems to have been my problem. All's good now though!

Thanks Everyone!

Mike
__________________
Michael Roth

1982 300TDT Wagon
1982 240D Euro!, 4spd manual-Parts car now, dead engine
88 Jeep Grand Wagoneer-fixing up for offroading
1989 Ford F150 (rust bucket) For Sale!
1953 Dodge B-4F, 1 1/2 ton Stake Bed (new restoration project)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1967 250SE voltage regulator dconnell Tech Help 0 07-24-2004 04:28 PM
Replace Lamps with LEDS Russo 85300tD Diesel Discussion 12 11-15-2003 07:18 PM
e320 alternator input voltage jbobo Tech Help 0 01-08-2003 10:10 PM
420SEL Idle Valve Voltage lleon1999 Tech Help 5 01-06-2003 06:35 PM
'83 240D voltage regulator ncarter Tech Help 5 01-04-2000 05:52 PM



All times are GMT -4. The time now is 07:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page