Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-28-2005, 02:02 PM
Registered User
 
Join Date: May 2005
Location: Prince Edward Island
Posts: 16
Fan keeps coming on

1990 300d,,,,auxillary fan keeps coming on and off when not needed,,,,whats the problem???and can I unhook it??
Reply With Quote
  #2  
Old 08-28-2005, 02:18 PM
dieselbeagel's Avatar
Registered User
 
Join Date: Nov 2003
Location: California
Posts: 334
A couple of things to check...

1) Is ur A/C charged ? If low, it could contribute to the probelm

2) There is a switch at the left front of the car, behind the head light. Connecting the 2 prongs sets the aux fan on. Is that okay ?

3) Check fuses. The fuse box has a diagram on the cover. I may be wrong but I believe it is the left front corner fuse (in the fuse box). Check if that is okay.

4) Faulty aux fan relay? This is located in the secondary fuse box (behind the main fuse box). Looking at the secondary fuse box from the front of the car, It is the 3rd relay from back of the box, in the left most row.
Reply With Quote
  #3  
Old 08-28-2005, 02:25 PM
Registered User
 
Join Date: Sep 2001
Location: central Texas
Posts: 17,277
You have such a new car that I have no manuals on it.. so I am just throwing out some possibilities....

Maybe your car is hooked up so that not just the temperature switch on the R/Dryer turns on the AUX fan... like maybe the engine needing more cooling ?

I sure would not unhook it unless it will come on by itself when the car engine is cold ( not running ) and is risking running down your battery...
Reply With Quote
  #4  
Old 08-28-2005, 02:48 PM
Registered User
 
Join Date: May 2005
Location: Prince Edward Island
Posts: 16
thanks,,,,I'll check these suggestions out,,,
Reply With Quote
  #5  
Old 08-28-2005, 05:08 PM
Geezer
 
Join Date: Aug 2000
Location: Holland, MI
Posts: 1,316
In the OM603 86 SDL, the R/D switch or the coolant 105C switch can activate the aux fan.

It might be a marginal 105C temp sensor, grounding and ungrounding the signal to the relay.

Just one more place to check.

Best Regards,
Jim
Reply With Quote
  #6  
Old 08-28-2005, 05:09 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 20,656
603 guru Dave M/gsxr says that the coolant temp sensor that triggers the aux fan can get flaky. Maybe this is its swan song.

Sixto
95 S420
87 300SDL
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
S350 fan clutch not operating as it should. rekatt Diesel Discussion 17 08-02-2005 06:15 AM
300E aux fan not coming on..HELP!! mike690003 Tech Help 6 10-07-2003 02:17 PM
'95 E320 operating temperature NikoE320 Tech Help 47 09-23-2003 04:05 AM
1990 300e over heated now no internal blower fan comeing on. ceward Tech Help 0 07-05-2003 01:15 AM
Aux fan not coming on, relays look good, what to check next? Larry Delor Tech Help 13 06-02-2003 12:16 PM



All times are GMT -4. The time now is 10:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page